Imac 21.5 mid 2011 2428

Moderatore: ModiMaccanici

Max_VCE
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: dom, 14 giu 2020 12:39
Messaggi: 15

Top

Oggetto del messaggio: Imac 21.5 mid 2011 2428

Messaggio da Max_VCE »

Ciao a tutti.

Eccomi di nuovo con un problema con un Mac di un mio amico.
Si tratta di un iMac 21.5 mid 2011 2428. A questa macchina è stato sostituito l'HD con un SSD da un laboratorio non Apple.
Tutto a posto per una settimana dopodiché macchina si pianta e al riavvio non carica più il sistema operativo.
E' stato riportato al laboratorio il quale ha risposto scheda madre andata.

Ed ecco che adesso ce l'ho io ( naturalmente senza SSD )

Prove effettuate:

All'avvio fa il solito Boing e il pannello si accende. Non avendo il disco dopo un po' appare la cartella con il punto di domanda.
1- Per prima cosa ho tolto le memorie ed ho acceso la macchina e il Mac ha risposto con il solito segnale di problemi alle memorie ( almeno la MB si accorge e fino a qui va )
2- istallo un HDD e provo a recuperare la versione di Ios da internet. Si collega correttamente alla WI-FI e inizia il download con il mappamondo che gira.
3- finisce di scaricare, appare la mela con il cursore e arriva fino a 3/4 poi schermata grigia e tastiera bloccata.
4- Effettuate tutte le combinazioni per pulire la memoria ma niente. Arriva fino a 3/4 e si blocca su una schermata grigia.
5- Verificati i 4 LED di diagnostica e si accendono correttamente in sequenza.

Facendo partire la diagnostica da internet appare questo errore hardware. 4NS /1/40000000: TH00-9.000

Questo sembra un errore legato al sensore di temperatura dell'HDD, ma di solito crea rallentamenti e fan che impazziscono.

Non ho il DVD originale. Alcuni scrivono che questa macchina parte solo con il suo IoS che era in dotazione, ma in tutti gli altri casi in cui
avevo fatti il download da internet si era scaricata l'ultima versione compatibile ed aveva sempre funzionato.

Ho anche provato nella disperazione totale ad istallare un HDD di un altro Mac ( sia MacBook che Mac mini ). All'avvio seleziono il disco di partenza e scelgo quello di ripristino. Ma il problema è lo stesso.

Se ben ricordo quando si reinstalla loS su un Mac quando c'è la mela con la barra che avanza, ad un certo punto lo schermo diventa un po' più scuro e appare il puntatore del mouse con una rotella colorata
che gira. Il problema sembra verificarsi in quel momento del caricamento.

Prima di cominciare a smontare la MB e verificare la GPU vi chiedo se avete qualche altra idea. A proposito sapete se questa versione dell'Imac ha sia la GPU esterna che quella su MB ?

Prima di bloccarsi nel caricamento funzionano anche le periferiche Tastiera, mouse, scheda WI-FI, Driver, scheda audio, collegamento con l'HDD, e le varie combinazioni dei tasti
per cui a me non sembrerebbe in prima battuta un problema alla MB.

Tutte le "Dritte" sono ben accette.
Grazie a tutti

Massimo

Avatar utente
fragrua
Stato: Non connesso
Admin of my life
Admin of my life
Avatar utente
Iscritto il: sab, 08 ott 2005 07:00
Messaggi: 59546
Località: [k]ragnano

Top

Oggetto del messaggio: Re: Imac 21.5 mid 2011 2428

Messaggio da fragrua »

Avvia da un sistema esterno e con un monitor esterno.
Potrebbe essere comunque la scheda grafica.
Immagine
La prima cosa su cui devi investire è il benessere del tuo corpo, l'unica cosa che ti porterai nella tomba.
Franz Grua (sarebbe fragrua)

In un mondo perfetto io sarei un essere inutile.
©2015 albertocchio

—> Uso corretto del Forum: https://goo.gl/9xOO0a

Immagine

Max_VCE
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: dom, 14 giu 2020 12:39
Messaggi: 15

Top

Oggetto del messaggio: Re: Imac 21.5 mid 2011 2428

Messaggio da Max_VCE »

Intanto grazie della risposta.
Ho avuto anch'io il sospetto potesse essere la scheda grafica.
Nel fine settimana farò alcune prove e poi ti farò sapere.

Massimo

Max_VCE
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: dom, 14 giu 2020 12:39
Messaggi: 15

Top

Oggetto del messaggio: Re: Imac 21.5 mid 2011 2428

Messaggio da Max_VCE »

Provo a riepilogare le prove fatte:

- Avvio del Imac con monitor esterno.
Premessa. Parte con un disco formattato e in cui ho scaricato l' IoS dalla rete. Dovrebbe essere l'ultimo compatibile.
Una volta scaricato parte la mela arriva fino a 3/4 e poi schermata grigia. Nel monitor esterno non si vede nulla finché la schermata non diventa grigia
quindi il monitor esterno si accende, ma anche questo con schermata grigia.

Consiglio:
- rispetto agli altri mac che ho avuto per le mani su questo non mi sembra si riesca smontare la scheda video senza disassemblare completamente la scheda madre.
Corretto o c'è qualche trucco che non conosco ? Dai tutorial in rete sembrerebbe di no.

Grazie
Massimo

Avatar utente
Hammarby
Stato: Non connesso
Unix Expert
Unix Expert
Avatar utente
Iscritto il: gio, 29 ott 2009 14:28
Messaggi: 4648
Località: Stockholm, SE

Top

Oggetto del messaggio: Re: Imac 21.5 mid 2011 2428

Messaggio da Hammarby »

Manuale di servizio dell'iMac 21.5" 2010, il tuo non dovrebbe essere molto diverso
https://tim.id.au/laptops/apple/imac/imac_27_mid10.pdf

Per procedure di riparazione, fai affidamento alle guide di ifixit
Ognuno è come Dio lo ha fatto, ahimé...
...e spesso peggio.

Cervantes

Max_VCE
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: dom, 14 giu 2020 12:39
Messaggi: 15

Top

Oggetto del messaggio: Re: Imac 21.5 mid 2011 2428

Messaggio da Max_VCE »

Grazie Hammarby per il manuale di servizio.
Tra oggi e domani proverò a smontare la scheda video. Ne ho una che dovrebbe essere compatibile.

Massimo