Grosso problema iMac 27” 2011

Moderatore: ModiMaccanici

alexgunner
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: ven, 12 mag 2017 01:08
Messaggi: 10

Top

Oggetto del messaggio: Grosso problema iMac 27” 2011

Messaggio da alexgunner »

Salve,
Ho un grosso problema col mio iMac 2011 27”. Vi spiego cosa mi è successo.
Qualche giorno fa mentre lo stavo usando, improvvisamente, si è spento. (Prima che diventasse nero ho visto lo schermo per un attimo blu).
Tutte le volte che ho provato a riavviarlo, è apparsa la mela con la barra di progresso, arrivata a circa 3/4 lo schermo diventa tutto grigio.
Ho fatto la diagnosi da internet (test approfondito) che non ha rilevato alcuna anomalia. Ho tentato tutti i recovery mode vari senza alcun risultato. Ho tentato col sistema operativo nella chiavetta usb, stesso risultato, mela con barra e poi schermo grigio.
Ho provato i banchi ram, provandoli anche singolarmente, niente da fare. La scheda video non credo sia in quanto avviandolo col tasto “alt” visualizza regolarmente tutti i volumi per l’avvio.
Se provo il recovery da internet mi appare un punto esclamativo sopra il mondo ed il codice errore 2105d (dovrebbe essere un problema col mio router).
Non so cos’altro provare. Avevo pensato anche all’hdd ma considerando che fallisce l’avvio anche da chiavetta usb lo escluderei.
Sarei molto grato a chiunque possa darmi qualche dritta.

Avatar utente
iMaurizio
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: ven, 12 set 2014 03:21
Messaggi: 2655

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da iMaurizio »

alexgunner ha scritto:
mer, 03 giu 2020 17:14
La scheda video non credo sia in quanto avviandolo col tasto “alt” visualizza regolarmente tutti i volumi per l’avvio.
Non ho capito come hai ricavato questa deduzione, comunque sia io proverei ad avviare col tasto maiuscole (Shift) premuto.


Riesce a terminare la procedura di avvio e trovarsi quindi in quella che si chiama modalità sicura ?
https://support.apple.com/it-it/HT201262

alexgunner
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: ven, 12 mag 2017 01:08
Messaggi: 10

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da alexgunner »

Ho escluso la scheda video perché mi si è già rotta qualche tempo fa e l’ho mandata a fare il reballing. La scheda mi causava delle bande rosa che non sono apparse adesso. Quando mi visualizza ad, esempio, i vari drive per l’avvio la grafica è perfetta...

L’avvio col tasto shift premuto non sortisce alcun effetto, vedo sempre la mela con la barra di caricamento che si interrompe al solito livello di progresso.

alexgunner
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: ven, 12 mag 2017 01:08
Messaggi: 10

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da alexgunner »

Comunque ripensandoci bene, la schermata grigia arriva più o meno nel momento in cui normalmente appariva la schermata di login..
Quindi credi che potrebbe essere ugualmente colpa della scheda video, anche non presentando bande o artefatti vari?

Avatar utente
iMaurizio
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: ven, 12 set 2014 03:21
Messaggi: 2655

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da iMaurizio »

Le bande e gli artefatti sono comunque una sorta di prova che la scheda video funziona, male ma funziona.
Ma quando non ci sono più non significa necessariamente che la scheda sia guarita e che funziona meglio della condizione precedente.

Teoricamente con il tasto Shift il Mac dovrebbe partire, ma se hai fatto molti avvii mancati, blocchi e spegnimenti forzati il sistema di avvio è compromesso.

L'ideale sarebbe avviare da una pennetta o un disco esterno che abbiano un sistema operativo sano, e a quel punto si preme il tasto shift. Se il mac parte al primo colpo purtroppo la diagnosi è quasi certa ed è riferita proprio al comparto video.

alexgunner
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: ven, 12 mag 2017 01:08
Messaggi: 10

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da alexgunner »

Non capisco, se da un altro disco o chiavetta si avvia regolarmente allora è la scheda video compromessa? In tal caso come farebbe a funzionare usando un altro disco? La scheda video è sempre quella..
Comunque ho provato ad avviare in safe mode dalla chiavetta di installazione creata appositamente ed il Mac si riavvia quasi immediatamente.
Un’altra cosa, non sono mai riuscito a visualizzare il menù OS utility del recovery mode 🤔

Avatar utente
iMaurizio
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: ven, 12 set 2014 03:21
Messaggi: 2655

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da iMaurizio »

alexgunner ha scritto:
gio, 04 giu 2020 19:38
ho provato ad avviare in safe mode dalla chiavetta di installazione creata appositamente ed il Mac si riavvia quasi immediatamente.
L'avvio in safe mode esclude tutti i servizi non essenziali, tra cui la scheda video.

alexgunner
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: ven, 12 mag 2017 01:08
Messaggi: 10

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da alexgunner »

Ok, ad ogni modo non si avvia nemmeno in safe mode. L’unica differenza è che quando lo provo avviando da hdd arriva lo schermo grigio a 3/4 della barra di progresso. Se lo provo invece avviando da chiavetta, il Mac si riavvia prima ancora che la barra di progresso appaia.
Non ci sto capendo molto...
Curiosità, se in safe mode viene esclusa la scheda video, cosa viene utilizzato per visualizzare gli eventuali menu? C’è un altro chip video incluso nella scheda madre?

Avatar utente
iMaurizio
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: ven, 12 set 2014 03:21
Messaggi: 2655

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da iMaurizio »

Non so di preciso come funzioni ma sì, la scheda madre evidentemente è in grado di gestire lo schermo (mi pare in bianco e nero o in grigi) giusto per accedere alle funzioni di base.

alexgunner
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: ven, 12 mag 2017 01:08
Messaggi: 10

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da alexgunner »

Quindi, ricapitolando, assunto che non parte nemmeno in safe mode (bypassando quindi la scheda video) e che non si avvia nemmeno da chiavetta usb (bypassando l’hdd) e che non si avvia nemmeno provando un banco di ram alla volta (ne ho 2 da 2gb e 2 da 4gb), quale altro potrebbe essere il problema?
Devo valutare se ricomprare un nuovo Mac oppure se cercare di sistemare questo che, comunque, per la mia operatività è ancora molto valido..

Avatar utente
iMaurizio
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: ven, 12 set 2014 03:21
Messaggi: 2655

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da iMaurizio »

alexgunner ha scritto:
ven, 05 giu 2020 13:00
non si avvia nemmeno da chiavetta usb (bypassando l’hdd)
Sei certo che la chiavetta USB sia un sistema di avvio compatibile e funzionante ?

E' da quel sistema che va tentato il safe mode, non dal disco interno.

Avatar utente
Simone.m
Stato: Non connesso
Hardware Expert
Hardware Expert
Avatar utente
Iscritto il: ven, 20 set 2013 23:58
Messaggi: 3312

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da Simone.m »

alexgunner ha scritto:
gio, 04 giu 2020 19:38
La scheda video è sempre quella..
No, in caso di avvio sicuro usa l'integrata.
Avevo un MacBook leggermente più vecchio, quei sintomi sono stati la sentenza di morte della scheda video.
MacBook Pro 13" (2011, i5 | 8GB | 256GB SSD)
iPhone SE (2017, 32GB)
iPad (2019, 32 GB, Cellular)

alexgunner
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: ven, 12 mag 2017 01:08
Messaggi: 10

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da alexgunner »

iMaurizio ha scritto:
ven, 05 giu 2020 20:52
alexgunner ha scritto:
ven, 05 giu 2020 13:00
non si avvia nemmeno da chiavetta usb (bypassando l’hdd)
Sei certo che la chiavetta USB sia un sistema di avvio compatibile e funzionante ?

E' da quel sistema che va tentato il safe mode, non dal disco interno.
La chiavetta usb che ho usato è quella fatta seguendo le istruzioni indicate qui..
https://support.apple.com/it-it/HT201372

alexgunner
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: ven, 12 mag 2017 01:08
Messaggi: 10

Top

Oggetto del messaggio: Re: Grosso problema iMac 27” 2011

Messaggio da alexgunner »

Simone.m ha scritto:
ven, 05 giu 2020 21:58
alexgunner ha scritto:
gio, 04 giu 2020 19:38
La scheda video è sempre quella..
No, in caso di avvio sicuro usa l'integrata.
Avevo un MacBook leggermente più vecchio, quei sintomi sono stati la sentenza di morte della scheda video.
Su questa già una volta ho fatto fare il reballing, un paio di anni fa, ma se l’intervento dura così poco forse non vale più la pena rifarlo..
Ho letto di un’azienda che sostituisce la Radeon con una GeForce più performante, potrebbe valerne la pena visto il costo ed il fatto che, vista l’età del Mac, presto non mi consentiranno più di aggiornarlo? (Già non mi fa più aggiornare il sistema operativo oltre high Sierra)
Questo è il link:
https://www.flashmac.com/prodotto/sosti ... 1-21-e-27/