Problema installazione applicazione terze parti

Moderatore: ModiMaccanici

Avatar utente
ekkelon
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: ven, 06 mar 2009 10:46
Messaggi: 76

Top

Oggetto del messaggio: Problema installazione applicazione terze parti

Messaggio da ekkelon »

Ciao a tutti,
devo installare una app. non scaricata dallo store ufficiale, ma quando la lancio il sistema mi dice che la applicazione è danneggiata e chiede di cestinarla.
Ho provato a disattivare GateKeeper con il comando ‘sudo SPCTL –master-disable‘ e sembra in effetti essere disattivato in quanto in sicurezza sulle app. installabili scaricate da ... appare "ovunque"
Però anche in questa situazione quando lancio la app. il problema è lo stesso.
Come potrei risolvere!?
Grazie 1000.

Avatar utente
faxus
Stato: Non connesso
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 29710
Località: Circondato dalle bufale

Top

Se lo fa anche quando, alla prima apertura, tieni premuto il tasto "⌃"?

Se puoi dirlo, di quale applicazione parli?
Quale versione e da dove l'hai scaricata?
E lo fa solo con quella?
Che sistema usi?

Avatar utente
ekkelon
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: ven, 06 mar 2009 10:46
Messaggi: 76

Top

faxus ha scritto:
mar, 14 gen 2020 10:35
Se lo fa anche quando, alla prima apertura, tieni premuto il tasto "⌃"?

Se puoi dirlo, di quale applicazione parli?
Quale versione e da dove l'hai scaricata?
E lo fa solo con quella?
Che sistema usi?
No, non ho provato col tasto che dici, ho provato tenendo prenuto CTRL e poi cliccando su APRI.

Avatar utente
faxus
Stato: Non connesso
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 29710
Località: Circondato dalle bufale

Top

ekkelon ha scritto:
mar, 14 gen 2020 11:03
... CTRL
È il tasto ⌃, infatti.

Le altre risposte?

Avatar utente
ekkelon
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: ven, 06 mar 2009 10:46
Messaggi: 76

Top

Si tratta di una patch per degli applicativi .....
:(

Avatar utente
faxus
Stato: Non connesso
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 29710
Località: Circondato dalle bufale

Top

Se lo fa solo con quella potrebbe essere corrotta effettivamente.

Prova a prenderla altrove

Avatar utente
Paolofast
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 3244

Top

Oggetto del messaggio: Re: Problema installazione applicazione terze parti

Messaggio da Paolofast »

Apri Terminale (Applicazioni —> Utility —> Terminale), aspetta il prompt (la scritta che compare dopo un po’ e finisce con $ e uno spazio).
Copiate ed incolla questo comando, SENZA le parentesi angolari < e >.

Codice: Seleziona tutto

sudo xattr -rd com.apple.quarantine 
compreso lo spazio in coda dopo la parola quarantine.

Trascina ora l’icona dell'app DENTRO la finestra del terminale. Il comando si completerà con il percorso esatto dell'app.
Una cosa del genere, ma con il percorso esatto dell'app.

ESEMPIO:

Codice: Seleziona tutto

sudo xattr -rd com.apple.quarantine /Applications/LaMiaApp.app
Premi invio e ti verrà chiesta la password utente.
Mettila, anche se Terminale non te la fa vedere, e premi invio.

Aspetta un po’ che torni il prompt (la scritta che compare dopo un po’ e finisce con $ e uno spazio).

Chiudi Terminale.

Ora l'app dovrebbe funzionare.
*
*
Se installando Yosemite, El Capitan, Sierra, High Sierra, Mojave o Catalina, il Mac vi dice che l'installer è danneggiato, non è danneggiato, ha il certificato scaduto. Leggete qui:
viewtopic.php?f=33&t=46076
In pratica o scarichi l'installer aggiornato o modifichi la data nell'orologio del Mac.

Avatar utente
ekkelon
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: ven, 06 mar 2009 10:46
Messaggi: 76

Top

Grazie .... stasera proverò e ti diro! Grazie 1000 ...

Avatar utente
ekkelon
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: ven, 06 mar 2009 10:46
Messaggi: 76

Top

Ciao... grande ... funziona!!!!
Grazie mille ....

Avatar utente
ekkelon
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: ven, 06 mar 2009 10:46
Messaggi: 76

Top

Ciao,
ho riprovato a fare la procedura, ho installato la app. Day One però dopo aver trascinato l'icona della APP da Applications all'interno della finestra terminale anziché chiedermi ls password mi esce una scritta del tipo:

Air-di-xxx:~ xxx$ /Applications/DayOne.app
-bash: /Applications/DayOne.app: is a directory
Air-di-xxx:~ xxx$

Ed ovviamente se lancio la app. non funziona e non si avvia!
Che sbaglio?
Grazie.

Avatar utente
Paolofast
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 3244

Top

Oggetto del messaggio: Re: Problema installazione applicazione terze parti

Messaggio da Paolofast »

ekkelon ha scritto:
mer, 05 feb 2020 21:56
Che sbaglio?
Grazie.
Non hai messo il comando.
Rileggi il mio post con attenzione.
*
*
Se installando Yosemite, El Capitan, Sierra, High Sierra, Mojave o Catalina, il Mac vi dice che l'installer è danneggiato, non è danneggiato, ha il certificato scaduto. Leggete qui:
viewtopic.php?f=33&t=46076
In pratica o scarichi l'installer aggiornato o modifichi la data nell'orologio del Mac.

Avatar utente
ekkelon
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: ven, 06 mar 2009 10:46
Messaggi: 76

Top

Ciao .... fatto .... avevi ragione ... come sempre del resto!!!
Grazie mille.

Avatar utente
Paolofast
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 3244

Top

Oggetto del messaggio: Re: Problema installazione applicazione terze parti

Messaggio da Paolofast »

ekkelon ha scritto:
gio, 06 feb 2020 21:10
Ciao .... fatto .... avevi ragione ... come sempre del resto!!!
Grazie mille.
Si può aver ragione su delle opinioni.
Sui fatti no: o sono veri o sono falsi di per sé, indipendentemente dalle opinioni.
Ed io mi attengo ai fatti.
*
*
Se installando Yosemite, El Capitan, Sierra, High Sierra, Mojave o Catalina, il Mac vi dice che l'installer è danneggiato, non è danneggiato, ha il certificato scaduto. Leggete qui:
viewtopic.php?f=33&t=46076
In pratica o scarichi l'installer aggiornato o modifichi la data nell'orologio del Mac.

Alex7
Stato: Non connesso
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: ven, 10 apr 2020 16:24
Messaggi: 4

Top

Paolofast ha scritto:
mar, 14 gen 2020 12:57
Apri Terminale (Applicazioni —> Utility —> Terminale), aspetta il prompt (la scritta che compare dopo un po’ e finisce con $ e uno spazio).
Copiate ed incolla questo comando, SENZA le parentesi angolari < e >.

Codice: Seleziona tutto

sudo xattr -rd com.apple.quarantine 
compreso lo spazio in coda dopo la parola quarantine.

Trascina ora l’icona dell'app DENTRO la finestra del terminale. Il comando si completerà con il percorso esatto dell'app.
Una cosa del genere, ma con il percorso esatto dell'app.

ESEMPIO:

Codice: Seleziona tutto

sudo xattr -rd com.apple.quarantine /Applications/LaMiaApp.app
Premi invio e ti verrà chiesta la password utente.
Mettila, anche se Terminale non te la fa vedere, e premi invio.

Aspetta un po’ che torni il prompt (la scritta che compare dopo un po’ e finisce con $ e uno spazio).

Chiudi Terminale.

Ora l'app dovrebbe funzionare.
Ciao, scusa ho eseguito il comando che hai suggerito però ora l'app non si avvia e non da più il messaggio "app danneggiata.....". Vedo solo 1 secondo l'icona nel dock e poi sparisce.
C'è un modo per ripristinare? Grazie!
(Imac27 su Catalina 10.15.4)

Avatar utente
Paolofast
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 3244

Top

Oggetto del messaggio: Re: Problema installazione applicazione terze parti

Messaggio da Paolofast »

Alex7 ha scritto:
ven, 10 apr 2020 16:28
Ciao, scusa ho eseguito il comando che hai suggerito però ora l'app non si avvia e non da più il messaggio "app danneggiata.....". Vedo solo 1 secondo l'icona nel dock e poi sparisce.
C'è un modo per ripristinare? Grazie!
(Imac27 su Catalina 10.15.4)
Dipende su cosa hai applicato il comando.
Comunque se butti l'applicazione e riscarichi/reinstalli l'originale avrai annullato qualunque effetto del comando.
Dopodiché ripensa al perché hai dato quel comando e se sia il caso di farlo ancora.
*
*
Se installando Yosemite, El Capitan, Sierra, High Sierra, Mojave o Catalina, il Mac vi dice che l'installer è danneggiato, non è danneggiato, ha il certificato scaduto. Leggete qui:
viewtopic.php?f=33&t=46076
In pratica o scarichi l'installer aggiornato o modifichi la data nell'orologio del Mac.