problemi egpu con mac mini 2018

Moderatore: ModiMaccanici

andreamac2
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mer, 08 gen 2020 14:49
Messaggi: 8
Oggetto del messaggio: problemi egpu con mac mini 2018

Messaggio Inviato: mer, 08 gen 2020 15:04

Ciao a tutti, e buon anno,
mi presento: mi chiamo Andrea e lavoro come grafico freelance, se pposibile volevo chiedere se qualcuno più competente può aiutarmi a risolvere un problema con una egpu.
Houn box sonnet 650 + Sapphire RX580 8GB, collegato a mac mini 2018 (i7 32BG di ram), OS 10.14.6 (Mojave)
il tutto ha funzionato bene per qualche mese (da ottobre 2019), alla rx580 sono collegati due monitor 24" tramite displayport, (nessun monitor collegato direttamente al mac mini), fino ad ieri accendendo il mac e aspettando qualche secondo, compariva la finestra di login, da questa mattinana, il mac si accende ma i monitor rimangano neri, (come spenti), collegando uno dei due monitor direttamente al mac il tutto torna a funzionare... la scheda viene riconosciuta (una cosa singolare è, mentre prima la finestra del login era con sfondo nero, adesso è diventata blu, non so se possa essere di aiuto...), ho provato anche a cambiare cavi dal box sonnet ai monitor, ho provato a mettere sia altre cavi displayport che cavi HDMI ma il risultato è lo stesso, non funziona più, torna a funzionare se un monitor a collegato direttamente al mac. Se può essere d'aiuto, oltre al box sonnet tramite thunderbolt 3 al mac mini sono collegati 2 HD Lacie Raid (un 2big dock e un 4big), un USB hub collegato tramite thunderbolt 3 al mac a cui sono collegati vari dispositivi.
Avete idea da cosa possa dipendere? non capisco se dipende dal macmini, dal box sonnet o dalla scheda video...

Grazie in anticipo
Andrea
Pingus
Expert
Expert
Avatar utente
Iscritto il: sab, 13 ott 2018 16:56
Messaggi: 541
Località: Polo Sud
Contatta:

Top

Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: gio, 09 gen 2020 13:59

Seguo...

I'm Pingù 🐧
kext
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: mer, 04 mar 2015 13:18
Messaggi: 4903
Contatta:

Top

Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: gio, 09 gen 2020 16:54

provo ad azzardare.. Sembra che "forse" con qualche aggiornamento del sistema operativo, la eGPU non venga riconosciuta più come "hardware primario" o che non "riconosca i monitor tramite eGPU".
Difatti MacOS in assenza di monitor collegati, disattiva la scheda grafica e gestisce tutto via software.
Dalla tua analisi sembra come se:

:arrow: macOS si avviasse con la scheda grafica "disabilitata" (sfruttando quella "via software")
:arrow: quando colleghi il monitor al mac, macOS "accende" il comparto grafico hardware
:arrow: quindi torna a funzionare anche l'estensione e la scheda eGPU

Ti consiglierei quindi di contattare il produttore e/o eventualmente effettuare un aggiornamento del firmware della eGPU.
Credo che, al massimo con 10 euro, potresti risolvere con un "headless HDMI": è una chiavetta HDMI che contiene un'elettronica basilare di un monitor (anche 4k).
Questa, collegata al mac, viene riconosciuta proprio come un monitor; questo "headless HDMI" viene usato spesso in ambito "server"..

Per farla breve e tenendo conto di quanto detto prima, quando si utilizzano mac senza monitor (headless, senza testa), collegano questa chiavetta ed evitano un affaticamento del processore evitando di usare la "gestione grafica software" (che grava appunto sul processore)..


Un headless lo puoi trovare qui https://www.amazon.it/dp/B07B9X8G7Z/ ma ce ne sono tanti altri..



p.s. seguo con interesse
ImmagineImmagine
andreamac2
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mer, 08 gen 2020 14:49
Messaggi: 8
Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: gio, 09 gen 2020 18:20

Grazie per per l'interessamento ed il consiglio per "headless HDMI" di cui non sapevo neanche l'esistenza...

proverò con questo "simula monitor" probabilmente risolvo in parte il problema, in quanto come detto se un monitor è collegato direttamente al mac mini tutto torna a funzionare regolarmente.
Quello che trovo strano è, non avendo fatto nessun aggiornamento, il fatto che da un giorno all'altro non venga più riconosciuta la scheda video esterna, avviandosi con la scheda grafica disabilitata.
La tua supposizione pare corretta
"macOS si avviasse con la scheda grafica "disabilitata"
infatti quando entrambi i monitor sono collegati alla eGpu in fase di avvio rimangono spenti, dopo l'avvio, collegando un monitor direttamente al mac questo non viene riconosciuto, continua a rimanere spento, proprio come se fosse disabilitato il comparto "video".

proverò a vedere se esiste un aggiornamento per l'eGpu, sia del box sonnet che della scheda video AMD (ma non credo è tutto molto recente)

su altro forum (egpu.io) un utente con configurazione simile alla mia ha riscontrato il solito problema, l'unica risposta che ha ottenuto è questa, che sembrerebbe dovuta proprio ad un aggiornamento:
- It happens if you upgrade or update MacOS or apply a security fix with the eGPU connected to the Mini. All MacOs updates need to be carried out with the eGPU disconnected and the monitor connected to the Mini or eGPU disconnected if connected to a laptop or unit with a screen

To sort out the problem connect the screen to the Mini and with the eGPU off reinstall Mac OSX once you have booted succesfully login disconnected the cable to the mini and switch on the eGPU

From there onwards will boot OK. In the odd case it does not from all devices off switch on in rapid sequence mini egpu and display - [/list][/list][/list]
il fatto è che io non ho fatto aggiornamenti... :roll:

Nel supporto Apple, riferiscono una situazione analoga nel caso sia attivo "FileVault" cosa che nel mio caso è disattivato.
Purtroppo sono in una zona dove la connessione è - Molto, molto LENTA- altrimenti potevo provare a installare su disco esterno un OS pulito, per vedere se dipende dal sistema operativo o dalle eGpu, tanto per escludere qualcosa.

Grazie ancora a Kext
kext
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: mer, 04 mar 2015 13:18
Messaggi: 4903
Contatta:

Top

Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: gio, 09 gen 2020 20:54

Hai un secondo Mac?
ImmagineImmagine
Paolofast
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 3030
Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: ven, 10 gen 2020 10:21

Prova questo: scollega tutto dal MacMini tranne tastiera, mouse ed un monitor collegato direttamente.
Fai il reset NVRAM accendendo il Mac tenendo premuti i tasti P+R+ALT+CMD e aspetta altri due riavvii prima di togliere le dita dalla tastiera.
Una volta avviato completamente, collega pure tutte le periferiche esterne.

Se la tastiera è una wireless a batterie a stilo, molto probabilmente il Mac non riceverà il comando, perciò cercane una a filo per fare l'operazione.
Se la tastiera è una wireless con porta lighting, collega la tastiera con il suo cavo di ricarica al Mac: funzionerà come se fosse a filo.

Ci sono buone possibilità che funzioni e tu non debba reinstallare (sempre con tutte le periferiche staccate) di nuovo il sistema operativo.
Se installando Yosemite, El Capitan, Sierra, High Sierra, Mojave o Catalina, il Mac vi dice che l'installer è danneggiato, non è danneggiato, ha il certificato scaduto. Leggete qui:
viewtopic.php?f=33&t=46076
In pratica o scarichi l'installer aggiornato o modifichi la data nell'orologio del Mac.
andreamac2
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mer, 08 gen 2020 14:49
Messaggi: 8
Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: ven, 10 gen 2020 12:42

si ho altri mac, ma non nuovissimi, non dispongono di T3, e con sistemi operativi fino al 10.10 quindi non posso provare con quelli...

Grazie Paolofast, già fatto il reset della NVRAM ma senza successo, se almeno un monitor non è collegato direttamente al mini, non funziona, non vengono riconosciuti
provato anche a fare un "reset" delle porte T3, tendo premuto per 10 secondi il pulsante di accensione
kext
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: mer, 04 mar 2015 13:18
Messaggi: 4903
Contatta:

Top

Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: ven, 10 gen 2020 12:53

andreamac2 ha scritto:
ven, 10 gen 2020 12:42
si ho altri mac, ma non nuovissimi, non dispongono di T3, e con sistemi operativi fino al 10.10 quindi non posso provare con quelli...

Pensavo a qualcosa di più semplice..

Per verificare se il macOS è in modalità hardware o software, basterebbe attivare la Condivisione dello schermo sul Mac dotato della eGPU; successivamente ti colleghi da un altro Mac "secondario" (Yosemite va bene) al Mac+eGPU e dovresti notare due cose lampanti:

:arrow: risoluzione "base", se non ricordo male viene attivata la 1024x768 o quella successiva (la 1280 credo)
:arrow: il desktop è quello di default, cioè quello che viene impostato in automatico da macOS dopo la configurazione utente..
:arrow: un punto aggiuntivo ma non di rilievo (perché dipende dal processore) è l'alto "consumo"/carico di lavoro del processore, misurabile nel Monitoraggio attività..

Fammi sapere..
ImmagineImmagine
Paolofast
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 3030
Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: ven, 10 gen 2020 13:59

andreamac2 ha scritto:
ven, 10 gen 2020 12:42
già fatto il reset della NVRAM ma senza successo,
Con tutto staccato, come ho scritto?
Altrimenti non funziona.
Se installando Yosemite, El Capitan, Sierra, High Sierra, Mojave o Catalina, il Mac vi dice che l'installer è danneggiato, non è danneggiato, ha il certificato scaduto. Leggete qui:
viewtopic.php?f=33&t=46076
In pratica o scarichi l'installer aggiornato o modifichi la data nell'orologio del Mac.
andreamac2
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mer, 08 gen 2020 14:49
Messaggi: 8
Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: ven, 10 gen 2020 16:30

Ciao,
allora si il reset l'ho fatto con tutto staccatto, con solo il un monitor collegato direttamente (non ho un cavo HDMI-HDMI ho provato con cavo USBC/T3-displayport, che serva un cavo HDMI-HDMI?)

per la prova proposta da kext:
allora fatta qualche prova,
1) con i monitor (1 o 2) collegati alla eGpu dall'altro computer neanche si avvia la condivisione (boh.. non so che dire), ho provato anche a mettere il login automatico in modo che non serva mettere password, ma lo stesso il mac mini non risulta visibile nella rete, se avvio senza eGpu e lascio tutto senza monitor allora vedo lo schermo condiviso con risoluzione "minima" quindi credo sia via software,

2) ho riprovato con il reset della NVRAM però con cavo HDMI-DVI (nel caso vadano lasciate libere le porte T3, se pensate sia il caso provo a procurarmi un cavo HDMI-HDMI), con la sola egpu attiva succede questo: il monitor si accende (come se ricevesse una sorta di segnale) ma rimane nero, e la condivisione schermo sull'altro computer non funziona, mentre funziona la condivisone documenti (qualcosa è cambiato)

3) con un solo monitor collegato tramite cavo HDMI-DVI funziona tutto, ma la condivisone monitor è come al punto (1) "schermata piccola", se attivo la eGpu viene riconosciuta ed entrambi i monitor funzionano, nella condivisone documenti la schermata è decisamente a risoluzione maggiore (1920x1200) per entrambi i monitor, anche quello che prima risultava con "schermo piccolo"

una volta avviato il sistema, con un monitor collegato direttamente, tutto funziona nella norma, posso utilizzare entrambi i monitor con egpu oppure lasciarne uno collegato al mini ed uno alla egpu
forse, azzardo, è un bug di OS X? almeno nella versione 10.14.6
andreamac2
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mer, 08 gen 2020 14:49
Messaggi: 8
Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: ven, 10 gen 2020 16:51

Che non abbia sbagliato qualcosa nel reset? ora che ci penso ho staccato tutto tranne il cavo di rete, può dipendere da quello? oltre che dal dubbio del cavo hdmi-hdmi :roll:
domani mi procuro un cavo hdmi-hdmi e riprovo
kext
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: mer, 04 mar 2015 13:18
Messaggi: 4903
Contatta:

Top

Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: ven, 10 gen 2020 20:55

andreamac2 ha scritto:
ven, 10 gen 2020 16:30
per la prova proposta da kext:
allora fatta qualche prova,
1) con i monitor (1 o 2) collegati alla eGpu dall'altro computer neanche si avvia la condivisione (boh.. non so che dire), ho provato anche a mettere il login automatico in modo che non serva mettere password, ma lo stesso il mac mini non risulta visibile nella rete, se avvio senza eGpu e lascio tutto senza monitor allora vedo lo schermo condiviso con risoluzione "minima" quindi credo sia via software,
Credo ci sia un conflitto con la eGPU dato quanto hai scritto.. quante e quali porte usi della scheda video (nel dettaglio, magari con una foto o schema)?

Giusto per completezza, la condivisione dello schermo si avvia già dalla schermata di login, quindi quando hai fatto la prova con la eGPU, non l'hai vista? Credo che il problema sia da ricercare qui perché è un comportamento anomalo..

Fammi sapere, la curiosità cresce!!
ImmagineImmagine
andreamac2
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mer, 08 gen 2020 14:49
Messaggi: 8
Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: sab, 11 gen 2020 11:18

Ciao,
ti confermo quanto scritto, ho appena riprovato
sarò un po' lungo ma almeno vi faccio il quadro genarale e completo

cavi collegati collegati alla egpu con cavo diplayport-displayport | provato anche a collegare un solo monitor con cavo DVI-DVI

con eGpu accesa e, sia con un monitor o con entrambi, collegati alla sola eGpu come descritto sopra:
- i monitor rimangono neri e in rete il mac mini non viene visto (come se fosse spento), anche se ovviamente è acceso, sia dal led sul fronte sia dalle periferiche connesse (come HDD ecc) i quali si avviano (perlomeno ricevono energia)
- i monitor sembra che ricevano una sorta di segnale, in quanto sembrano accendersi (il led del monitor si accende) e "navigando" tra le varie connessioni possibili, mentre con connessioni errate riportano "segnale assente" impostando la connessione corretta "non compare nessuna scritta" come se il segnale fosse presente, però ripeto rimangono completamente neri (come spenti)

Con egpu spenta e nessun monitor collegato: tutto funziona regolarmente, il mac mini compare nella rete, è possibile la condivisione dello schermo a partire dalla finestra di login

Con un monitor collegato direttamente al macmini (sia solo collegamento diretto che assieme alla egpu, o accendendo dopo l'avvio la scheda video esterna) tutto funziona regolarmente

Box GPU: sonnet egfx breakaway box 650
Scheda video: AMD Sapphire pulse RX580 8GB
la sceda video dispone di: 1xDVI - 2xHDM - 2xDisplayport, (per maggiori dettagli vedi link https://www.sapphiretech.com/en/consume ... -580-8g-g5)

La connessione che era sempre andata è la seguente
mac mini 2018 -> cavo T3 <- box egpu -> 2 cavi Displayport collegati a monitor a 2 EIZO 24" serie CG

tutto a sempre funzionato regolarmente, certo non vedevo la mela all'accensione, compariva la finestra di login, una mattina tutto questo a smesso di funzionare...
OS: 10.14.6

Precisazione (non so se può essere utile): la mattina che ha smesso di funzionare, (OS 10.14.6) la prima volta accendendo e spengendo la egpu era tornato a funzionare con la sola nota chela finestra di login aveva sfondo blu e non con lo sfondo impostato/personalizzato, sempre lo stesso giorno era disponibile nuovamente un aggiornamento per versione OS 10.14.6 ( :shock: ) ho fatto fare tale aggiornamento con egpu collegata...
contattato anche il supporto Apple i quali non sanno niente, mi confermano però che tale aggiornamento uscito a dicembre era relativo ad un aggiornamento di sicurezza, per egpu buio assoluto, mi fanno fare reset sia delle porte T3 che reset NVRAM come proposto da "Paolofast", però mi dicono di lasciare tutto connesso... in seguto poi ho anche provato a staccare tutte pe porte e fare i passaggi suggeriti da "Paolofast" ma niente non funziona, perlomeno a me non funziona anche se ad altri con situazioni analoghe sembra aver funzionato (una differenza come dicevo è che io non collego i monitor con cavo HDMI-HDMI, che sia quello, mi pare assurdo, ma proverò anche se sono convinto che non cambi niente. Sembra però anche a chi a funzionato che dopo pochi riavvi il problema si ripresenti, riporto questo link
https://egpu.io/forums/mac-setup/os-x-1 ... r-working/
kext
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: mer, 04 mar 2015 13:18
Messaggi: 4903
Contatta:

Top

Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: sab, 11 gen 2020 15:21

Confermo la mia prima tesi allora: quell'aggiornamento ha apportato delle modifiche e quindi qualcosa è non più compatibile..

Ti restano due strade.. piallare tutto oppure fare una installazione pulita su un hard disk/SSD esterno e vedere come va..
ImmagineImmagine
andreamac2
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mer, 08 gen 2020 14:49
Messaggi: 8
Oggetto del messaggio: Re: problemi egpu con mac mini 2018

Messaggio Inviato: lun, 13 gen 2020 08:49

Si, immaginavo, faro la prova di un'istallazione su HDD esterno, dovrò vedere come fare perchè, come dicevo, purtroppo sono in una zona dove la connessione è molto lenta...
ringrazio per il tempo che mi avete dedicato

appena riesco a fare la prova vi aggiorno, se volte, su come è andata
ammenoché nel frattempo la apple non rilasci un'aggiornamento che risolva questo problema

grazie di nuovo
Rispondi