Malware ... aiuto!

Mac OS X e le sue Applicazioni

Moderatore: ModiMaccanici

Jethro
Expert Retrogamer
Expert Retrogamer
Avatar utente
Iscritto il: sab, 04 lug 2009 22:26
Messaggi: 2428
Oggetto del messaggio: Re: Malware ... aiuto!

Messaggio Inviato: mer, 17 apr 2019 13:30

Chappy ha scritto:
mer, 17 apr 2019 00:53
Inoltre riporto un'anomalia del forum, questo messaggio è stato postato 15 minuti fa circa e ritrovo l'ora del messaggio di un'ora abbondante indietro
Siamo OT, comunque è di facile soluzione e non è un'anomalia del forum ma semplicemente una preferenza del tuo utente.

Pannello di Controllo Utente:
Immagine

E poi, Preferenze:
Immagine
MacBook Pro Retina 15"
i7 quad-core 2.6GHz, 16GB RAM, SSD 1TB, Iris Pro/GeForce GT 750M

----
8) La mia piccola collezione di "giochini":
https://www.flickr.com/photos/140997970@N07/albums
faxus
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 26207
Località: Due Sicilie
Contatta:

Top

Oggetto del messaggio: Re: Malware ... aiuto!

Messaggio Inviato: mer, 17 apr 2019 18:56

Chappy ha scritto:
mer, 17 apr 2019 00:53
Purtroppo il problema dei pop-up su google chrome persiste sul mio MacBook...
Se si tratta di Shlayer non serve.

Posta la finestra Profile di DetectX.
Non ho tempo, come sai, ma basterà un'occhiata per stabilirlo
Chappy ha scritto:
mer, 17 apr 2019 00:53
... riporto un'anomalia del forum, questo messaggio è stato postato 15 minuti fa circa e ritrovo l'ora del messaggio di un'ora abbondante indietro...
Vai al pannello del tuo utente e regola l'ora considerando l'ora estiva legale +1
R0ME0
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: sab, 22 mar 2014 11:11
Messaggi: 78
Oggetto del messaggio: Re: Malware ... aiuto!

Messaggio Inviato: ven, 19 apr 2019 18:10

Kundalini ha scritto:
mar, 16 apr 2019 20:51
R0ME0 ha scritto:
lun, 15 apr 2019 23:39

...Fantastico! Ha funzionato!...


Mi fa piacere.
R0ME0 ha scritto:
lun, 15 apr 2019 23:39
...Grazie infinite...
Ringrazio per i ringraziamenti :D , ma ci tengo a dire che non è solo farina del mio sacco; buona parte del merito va a Mauripucci, che se non ricordo male per primo ha postato la soluzione, citandone anche la fonte, in questa discussione viewtopic.php?f=9&t=44843&start=15#p493235
Io mi sono limitato a segnarmela nei miei appunti, nel caso ve ne fosse bisogno in un'eventualità futura, come in effetti è stato.
R0ME0 ha scritto:
lun, 15 apr 2019 23:39
Se riesci a risolvermi anche per Safari sarebbe grandioso!
Eh, magari bastassero 6 comandi per risolvere la situazione.
Una volta, fino a Mavericks, era presente nel menù di Safari la voce Ripristina. Ora non più.

Ipotizzando che il tuo Mac non sia vittima di Shlayer, visto che con Chrome le cose sono andate a buon fine e l'utente non dovrebbe essere infettato, hai diverse alternative, a mio parere.

1) se hai un backup con Time Machine potresti ripristinare Safari da lì (Time Machine > Applicazioni > Safari > Ripristina) avendo l'accortezza di andare indietro nel tempo ad un momento in cui Safari funzionava regolarmente. Certo dovresti esser sicuro di una data di TM con Safari sano.

2) reinstallare tutto il sistema, sovrascrivendolo (senza inizializzazione del disco) da Recovery; non perderesti i dati e non toccheresti l'utente. Questo naturalmente sempre nell'ipotesi che non si trattasse di Shlayer, con corruzione dell'utente appunto, altrimenti l'operazione non è utile.

3) ho ritrovato i comandi della discussione che ricordavo, caricati da faxus. Era questa viewtopic.php?f=10&t=45138&p=496637&hil ... be#p496604
Al netto dei suggerimenti per eliminare MacKeeper, ci sono le istruzioni per ricostruire Safari. Operazione che io personalmente non ho mai eseguito, sempre meglio avere un backup a portata di mano, secondo me.

Tra l'altro in quella discussione si possono pure trovare i comandi per Chrome che avevo indicato ieri :wink:

4) ripetere DetectX e caricare la risposta di come è adesso il tuo Mac. Magari si riesce ad individuare la ragione del malfunzionamento di Safari.
Grazie mille per i suggerimenti.
Non avendo risolto, ho chiamato il supporto Apple che mi ha risolto il problema in Safari. Inserendo questo codice tramite terminale:

defaults delete ~/Library/Containers/com.apple.Safari/Data/Library/Preferences/com.apple.Safari.plist AppleLanguages

ho risolto il problema. Spero possa essere utile anche ad altri con lo stesso problema. Grazie a tutti.
Rispondi