Mountain Lion is avvia in modalità "non grafica" ???

Tutto quello che riguarda OS X Mountain Lion 10.8 ed il suo predecessore OS X Lion 10.7

Moderatore: ModiMaccanici

Avatar utente
caporosso072
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: lun, 07 nov 2011 13:24
Messaggi: 21
Località: Milano / Roma

Top

Oggetto del messaggio: Mountain Lion is avvia in modalità "non grafica" ???

Messaggio da caporosso072 »

Ciao a tutti.

Ho fatto l'aggiornamento da Snow Leopard direttamente a Mountain Lion: non ho fatto un aggiornamento pulito, ho semplicemente scaricato osx da appstore ed installato sopra.

Non ho nessun problema, anzi mi sembra che il mio iMac da 24' late 2009 vada anche meglio.

L'unico problema è che molto spesso si avvia in modalità "testo", non so quale è il termine esatto, ma di fatto si avvia come un Unix normale senza interfaccia grafica, a riga di comando. Nessun errore, niente, semplicemente si avvia e mi lascia alla fine con il prompt su root. Io non faccio altro che digitare il comando di reboot e riparte senza problemi, caricando anche l'interfaccia grafica.

Qualcuno mi sa dire come fare in modo che non lo faccia??

Grazie

Avatar utente
Kernel Panic
Stato: Non connesso
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 29083
Località: Sicilia

Top

Oggetto del messaggio: Re: Mountain Lion is avvia in modalità "non grafica" ???

Messaggio da Kernel Panic »

E' possibile che quando avevi Snow Leopard tu abbia abilitato l'utente root e abbia poi effettuato l'upgrade a Mountain Lion sempre da root?


[Messaggio editato]
Ultima modifica di Kernel Panic il ven, 14 set 2012 17:44, modificato 1 volta in totale.

Avatar utente
ndin
Stato: Non connesso
Expert Latitante
Expert Latitante
Avatar utente
Iscritto il: mer, 02 giu 2010 10:11
Messaggi: 1963
Località: Konoha

Top

Temo che la modalità non sia verbose, ma "single user", che indica qualche mal funzionamento nelle estensioni del kernel. In verbose dovrebbe poi avviare da solo l'interfaccia grafica. Invece in single user appare il prompt dell'utente o ( se abilitato) di root. http://support.apple.com/kb/HT1492" onclick="window.open(this.href);return false;
L'avvio come utente singolo disabilita molte estensioni del kernel e non avvia interfaccia grafica.
Quindi chiedo: hai delle kext installate (Parallels, VMWare, virtuabox installano etensioni del kernel)? Come chiesto da KP, hai abilitato tu l'utente root?
La vita di uno shinobi non viene misurata in base a come ha vissuto, ma in base a ciò che ha fatto prima della morte.

Avatar utente
robertos
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: ven, 17 lug 2009 18:52
Messaggi: 5487
Località: Roma

Top

o piuttosto, visto che non è un difetto costante, non è che hai qualche problema con il tasto "S" che magari talvolta si incastra?

perché è proprio lui che, premuto all'avvio, fa partire il mac in "single user" con il comportamento che hai descritto,
mentre invece il "verbose mode" passa automaticamente alla modalità grafica, come detto da ndin

io ci darei un'occhiata!

al limite puoi provare ad avviare senza niente collegato (tastiera, mouse...) se lo fa lo stesso segui le indicazioni/domande di ndin
Non forzare nessuno a passare a Mac, altrimenti diventerai suo schiavo per sempre! © franz
Fixing the world, one piece of hardware at a time. © iFixit

Avatar utente
Kernel Panic
Stato: Non connesso
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 29083
Località: Sicilia

Top

Oggetto del messaggio: Re: Mountain Lion is avvia in modalità "non grafica" ???

Messaggio da Kernel Panic »

Avete assolutamente ragione.

Per evitare che l'utente possa avere altri problemi ho editato il mio primo messaggio.

Segnalo anche questa pagina: https://discussions.apple.com/thread/42 ... 0&tstart=0" onclick="window.open(this.href);return false;

Avatar utente
caporosso072
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: lun, 07 nov 2011 13:24
Messaggi: 21
Località: Milano / Roma

Top

Oggetto del messaggio: Re: Mountain Lion is avvia in modalità "non grafica" ???

Messaggio da caporosso072 »

Si, mi sembra si avvi in "single user", ma non sono un gran smanettone, non credo di aver abilitato l'utente root.
Ho installato anche Virtual box, ma lo avevo anche su Leopard e non ha mai dato problemi: e poi, non lo uso mai... Ho installato applejack, se può essere questo.
Il tasto S non credo di avere problemi: ho la tastiera Bluetooth!!

Che posso fare?

Avatar utente
ndin
Stato: Non connesso
Expert Latitante
Expert Latitante
Avatar utente
Iscritto il: mer, 02 giu 2010 10:11
Messaggi: 1963
Località: Konoha

Top

Disinstalla virtualbox col suo uninstaller. Poi cerca con EasyFind anche gli altri files col nome virtualbox e vbox. Magari una kext si è corrotta nell'aggiornamento. Applejack non puoi disinstallarlo al volo. Ma non credo sia colpa sua.
La vita di uno shinobi non viene misurata in base a come ha vissuto, ma in base a ciò che ha fatto prima della morte.

Avatar utente
caporosso072
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: lun, 07 nov 2011 13:24
Messaggi: 21
Località: Milano / Roma

Top

Oggetto del messaggio: Re: Mountain Lion is avvia in modalità "non grafica" ???

Messaggio da caporosso072 »

Aggiornamento:
mi si apre come 'single user' in modalità Verbose...

riguardo Virtual box, ieri ho aggiornato la versione alla 4.11 .. se è lui, lo tolgo nel primo pomeriggio e poi vedo.

Avatar utente
Kernel Panic
Stato: Non connesso
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 29083
Località: Sicilia

Top

Oggetto del messaggio: Re: Mountain Lion is avvia in modalità "non grafica" ???

Messaggio da Kernel Panic »

Pare che tu non sia il solo ad avere questo problema dopo l'upgrade a Mountain Lion con installazione semplice.

Intanto assicurati di non essere loggato come root, se lo sei devi uscirne (devi disabilitare l'utente root).

Hai aggiornato il sistema al 10.8.1?

Dai anche una lettura alla discussion che ti avevo segnalato sopra e prova a reimpostare PRAM e NVRAM.
Ultima modifica di Kernel Panic il sab, 15 set 2012 12:50, modificato 2 volte in totale.

Avatar utente
caporosso072
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: lun, 07 nov 2011 13:24
Messaggi: 21
Località: Milano / Roma

Top

Oggetto del messaggio: Re: Mountain Lion is avvia in modalità "non grafica" ???

Messaggio da caporosso072 »

Ti sono molto grato...
ma non so assolutamente come fare le cose che mi suggerisci.. :oops: :oops:
(e si, ho installato da App Store direttamente 10.8.1)

come si fa?
c'è una guida??

Avatar utente
Kernel Panic
Stato: Non connesso
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 29083
Località: Sicilia

Top

Oggetto del messaggio: Re: Mountain Lion is avvia in modalità "non grafica" ???

Messaggio da Kernel Panic »

caporosso072 ha scritto: .... come si fa?
c'è una guida??
Per quanto riguarda l'utente root su Mountain Lion vedi qui: http://support.apple.com/kb/PH11331?viewlocale=it_IT" onclick="window.open(this.href);return false;

Per la reimpostazione della PRAM: http://support.apple.com/kb/HT1379?viewlocale=it_IT" onclick="window.open(this.href);return false;

Aggiungo che puoi provare ad uscire definitivamente dalla modalità dettagliata anche con un comando da Terminale: http://osxdaily.com/2007/03/25/always-b ... bose-mode/" onclick="window.open(this.href);return false;

Avatar utente
caporosso072
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Avatar utente
Iscritto il: lun, 07 nov 2011 13:24
Messaggi: 21
Località: Milano / Roma

Top

Oggetto del messaggio: Re: Mountain Lion is avvia in modalità "non grafica" ???

Messaggio da caporosso072 »

Aggiornamento:

nemmeno il passaggio dalla 10.8.1 alla 10.8.2 ha risolto il problema, solo che ora lo fa sempre.. la prima volta che lo accendo.
disintallato Virtualbox e ripulito la cache di avvio, niente.

La prossima volta pulirò la PRAM : ma qualcuno altro ha lo stesso problema??

massy67
Stato: Non connesso
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mer, 26 set 2012 08:24
Messaggi: 1

Top

Ciao a tutti ho il tuo stesso problema, mi fai sapere se sei riuscito?
Con una installazione da zero, che vorrei però evitare, il problema si risolve?

Avatar utente
Kernel Panic
Stato: Non connesso
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 29083
Località: Sicilia

Top

Oggetto del messaggio: Re: Mountain Lion is avvia in modalità "non grafica" ???

Messaggio da Kernel Panic »

massy67 ha scritto:Con una installazione da zero, che vorrei però evitare, il problema si risolve?
Se non si risolve nemmeno con una installazione da zero occorre l'esorcista ..... Immagine

mentalità
Stato: Non connesso
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mer, 10 ott 2012 22:01
Messaggi: 2

Top

Stesso problema, presentatosi con mountain lion. Ho quindi formattato ed eseguito un'installazione pulita.
Credevo si fosse tutto risolto...credevo! :banghead: :banghead: :banghead: :banghead: :banghead: :banghead: :banghead:
Da quando ho formattato, ho copiato dall'hd esterno solo la musica ed ho poi installato solamente qualche applicazione per l'utilizzo di tutti i giorni. Tra queste ho installato wineskin, ma mai utilizzato, solo configurato un "contenitore".
Che possa essere lui il responsabile? Che ne pensate?
Il fatto è che prima di formattare, avevo cancellato tutte le applicazioni sospette, ma non avevo risolto...