Non riesco ad installare Snow Leopard su un MacBook Pro 1.1!

Problemi con il Mac, componenti o periferiche

Moderatore: ModiMaccanici

Massimiliano_S
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: lun, 20 ago 2012 23:08
Messaggi: 47

Top

corci ha scritto:
Zen ha scritto:@corci

È solo la cartella extensions, senno prendi mezzo sistema ;)
Quella di tiger occupa 130 mb, quella di snow leopard 360. Le ho zippate e ora occupano 140 mb in tutto, ma dato che la mia connessione è lenta ci vogliono 3 ore per terminare l'upload. :-)


– Io scrivo su iMaccanici con iPad e Tapatalk –

Ah, ma a me basta Tiger, caro corci!

Avatar utente
corci
Stato: Non connesso
Maccanico assiduo
Maccanico assiduo
Avatar utente
Iscritto il: ven, 14 set 2007 15:38
Messaggi: 138

Top

Hai pm.


– Io scrivo su iMaccanici con iPhone e Tapatalk –

Massimiliano_S
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: lun, 20 ago 2012 23:08
Messaggi: 47

Top

Oggetto del messaggio: Re: Non riesco ad installare Snow Leopard su un MacBook Pro

Messaggio da Massimiliano_S »

Grazie corci, ricevuto ed installato. Non ci siamo ancora, anzi: kernel panic al riavvio e col riavvio in modalità Safe "perdo" tastiera e trackpad, e non riesco a dargli l'ok per la partenza.
Non mi ha copiato tutti i kext. Un paio erano "in uso" e non c'è stato niente da fare. Ho sperato ottimisticamente che non fossero proprio quelli gli str..., ma evidentemente mi sbagliavo.
Quasi inutile dire che il solito tentativo di ripartenza dall'hd esterno è stato accolto con il solito schermo blu.

Suggerimenti? La mia pazienza sta per esaurirsi, immagino la vostra.

EDIT: ho collegato una tastiera Apple Usb, d'epoca, ma niente neppure con quella.

Avatar utente
Zen
Stato: Non connesso
Unix Expert
Unix Expert
Avatar utente
Iscritto il: sab, 14 gen 2012 01:24
Messaggi: 2435

Top

Non ci siamo ancora, anzi: kernel panic al riavvio e col riavvio in modalità Safe "perdo" tastiera e trackpad, e non riesco a dargli l'ok per la partenza.
Se riavvii in modalità testuale riesci a recuperare le funzionalità di prima con un comando da terminale che rimette le estensioni a posto.

sudo cp [cartella extensions backup]/* /System/Library/Extensions

Ti posso aiutare meglio se mi dici dove l'hai messa/e quelle vecchie.

Comunque credo che l'unico modo sia ottenere un qualche lettore cd e provare da quello.

Massimiliano_S
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: lun, 20 ago 2012 23:08
Messaggi: 47

Top

Oggetto del messaggio: Re: Non riesco ad installare Snow Leopard su un MacBook Pro

Messaggio da Massimiliano_S »

Zen ha scritto:
Non ci siamo ancora, anzi: kernel panic al riavvio e col riavvio in modalità Safe "perdo" tastiera e trackpad, e non riesco a dargli l'ok per la partenza.
Se riavvii in modalità testuale riesci a recuperare le funzionalità di prima con un comando da terminale che rimette le estensioni a posto.

sudo cp [cartella extensions backup]/* /System/Library/Extensions

Ti posso aiutare meglio se mi dici dove l'hai messa/e quelle vecchie.

Comunque credo che l'unico modo sia ottenere un qualche lettore cd e provare da quello.
Le vecchie sono in una chiavetta usb, cartella "Extensions old".

Ma mi spieghi una cosa di principio? Quando il sistema collassa in questo modo, non dovrebbe essere progettato per farsi soccorrere abbastanza facilmente dall'esterno? Porca vacca, sono giorni e giorni che cerchiamo d fargli leggere un hd/chiavetta con ogni tipo di installer ecc. ecc.
Capisco che l'installazione corretta si fa dal cd, per queste macchine, ma se questo si rompe? Tantopiù che si rompono TUTTI.

Grazie di nuovo

Avatar utente
Zen
Stato: Non connesso
Unix Expert
Unix Expert
Avatar utente
Iscritto il: sab, 14 gen 2012 01:24
Messaggi: 2435

Top

Le vecchie sono in una chiavetta usb, cartella "Extensions old".
Argh, la cosa si fa più complessa in questo caso... perché richiede un minimo di conoscenze del terminale

Se appunto fai il boot testuale e fai il login, puoi fare così:

Attacchi la chiavetta. Speri che il sistema la monti e la trovi così:

Codice: Seleziona tutto

ls -1 /Volumes/
Ci dovrebbe essere una cartella con il nome della chiavetta.

A questo punto fai:

Codice: Seleziona tutto

sudo cp /Volumes/nome_chiavetta/Extensions\ old/* /System/Library/Extensions/
Fai conto che se il nome della chiavetta contiene spazi devi farli precedere da un \
ad esempio "ciao\ come\ va" ;)
Ma mi spieghi una cosa di principio? Quando il sistema collassa in questo modo, non dovrebbe essere progettato per farsi soccorrere abbastanza facilmente dall'esterno? Porca vacca, sono giorni e giorni che cerchiamo d fargli leggere un hd/chiavetta con ogni tipo di installer ecc. ecc.
Capisco che l'installazione corretta si fa dal cd, per queste macchine, ma se questo si rompe? Tantopiù che si rompono TUTTI.
Di principio l'idea è giusta, però fai conto che si parla di un sistema vecchio. Non a caso Lion e Mountain Lion hanno una partizione di ripristino :).

Avatar utente
kato
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: ven, 12 nov 2010 15:16
Messaggi: 4856
Località: Roma

Top

Zen, fammi capire. In caso di avvio da unità esterna, i kext se li prenderebbe comunque da quella interna? :shock: A me questa storia suona molto strana ma forse me non capire o non sapere.

Massimiliano_S
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: lun, 20 ago 2012 23:08
Messaggi: 47

Top

Niente, si è piantato di brutto. Non prende nessun comando dalla tastiera.
Urge trovare questo lettore dvd, temo.

Massimiliano_S
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: lun, 20 ago 2012 23:08
Messaggi: 47

Top

Oggetto del messaggio: Re: Non riesco ad installare Snow Leopard su un MacBook Pro

Messaggio da Massimiliano_S »

kato ha scritto:Zen, fammi capire. In caso di avvio da unità esterna, i kext se li prenderebbe comunque da quella interna? :shock: A me questa storia suona molto strana ma forse me non capire o non sapere.
Ecco: è proprio questo che mi sembra del tutto assurdo.

Avatar utente
Zen
Stato: Non connesso
Unix Expert
Unix Expert
Avatar utente
Iscritto il: sab, 14 gen 2012 01:24
Messaggi: 2435

Top

Zen, fammi capire. In caso di avvio da unità esterna, i kext se li prenderebbe comunque da quella interna? A me questa storia suona molto strana ma forse me non capire o non sapere.
No no, se c'è un sistema sull'unità esterna e viene avviato li prende da lì, altrimenti no, usa sempre quelli dell'interna.

Avatar utente
kato
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: ven, 12 nov 2010 15:16
Messaggi: 4856
Località: Roma

Top

Zen ha scritto:No no, se c'è un sistema sull'unità esterna e viene avviato li prende da lì, altrimenti no, usa sempre quelli dell'interna.
Eh, ma allora, se dice che il problema si manifesta anche con avvio da unità esterna, mi pare una prova inutile.

Avatar utente
Zen
Stato: Non connesso
Unix Expert
Unix Expert
Avatar utente
Iscritto il: sab, 14 gen 2012 01:24
Messaggi: 2435

Top

Eh, ma allora, se dice che il problema si manifesta anche con avvio da unità esterna, mi pare una prova inutile.
Me lo sono perso :)
E aggiungo che forse semplicemente non è partito da unità esterna :D , provato senza avere l'hd interno?

Avatar utente
kato
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: ven, 12 nov 2010 15:16
Messaggi: 4856
Località: Roma

Top

Zen ha scritto:Me lo sono perso :)
Così ho capito ma, alla sesta pagina di interrogatorio, ho dubbi pure su chi sono io.

Avatar utente
Zen
Stato: Non connesso
Unix Expert
Unix Expert
Avatar utente
Iscritto il: sab, 14 gen 2012 01:24
Messaggi: 2435

Top

Così ho capito ma, alla sesta pagina di interrogatorio, ho dubbi pure su chi sono io.
:D
Non sarebbe male fare il punto della situazione.

Massimiliano_S
Stato: Non connesso
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: lun, 20 ago 2012 23:08
Messaggi: 47

Top

Oggetto del messaggio: Re: Non riesco ad installare Snow Leopard su un MacBook Pro

Messaggio da Massimiliano_S »

Punto della situazione:

Il problema - MacBook Pro (1,83 GHz con 512 MB di ram, Mac Os X 10.4.11 Tiger) non si avvia regolarmente. Compare la mela grigia per qualche secondo, la rotellina gira, poi tutto si pianta su una schermata blu.
Parte in modalità Safe senza problemi. Il maledetto lettore dvd non funziona.

I tentativi - Ho tentato di farlo partire da un hd esterno Usb, con partizione GUID. Ho provato con installer (clonati dai dischi retail con Disk Utility), ed anche con vere e proprie installazioni di Os X, versioni 10.4, 10.5 ed anche 10.6. Quest'ultima, solo dopo aver aggiornato la ram a 2 GB, perchè con i 512 MB si era al di sotto dei requisiti.
In ogni caso, la situazione che si verifica è sempre la stessa: avviato il MBP col tasto opzione e scelta l'unità esterna, l'avvio ha inizio ma non termina, e tutto si pianta su schermate "a mosaico" oppure sul consueto schermo blu.
Idem per tentativi da chiavetta Usb.

Il disco è stato controllato con Disk Utility e con AppleJack, è stato resettato il resettabile (Pram, EFI, SMC...).

Ieri abbiamo tentato di applicare la combo update (a partire dall'avvio Safe, con successo) e poi anche di sostituire i kext sull'installazione presente (10.4.11), ma il risultato è stato un kernel panic e l'impossibilità di usare tastiera e trackpad.