Problema con condivisione web

L'archivio del forum de iMaccanici

Moderatore: ModiMaccanici

Avatar utente
lordbye
Stato: Non connesso
Geniale
Geniale
Avatar utente
Iscritto il: mar, 11 mar 2008 12:47
Messaggi: 2058
Località: Milano - Città Studi

Top

Oggetto del messaggio: Problema con condivisione web

Messaggio da lordbye »

Ciao a tutti,

ho fatto una prova, abilitando la condivisione web a me all'indirizzo suggerito nelle preferenze
http://10.0.1.2/~lordbye/ (sono collegato a fastweb tramite airport e la momento questo è l'IP che mi da la airport) mi dice

Safari non può collegarsi al server.
Safari non può aprire la pagina “http://10.0.1.2/~lordbye/” perché non può collegarsi al server “10.0.1.2”.



Come si fa ad attivare la condivisione web ed avere apache attivo senza installare mamp??

ps: da terminale dando sudo apachectl start mi dice che il servizio e gia attivo

delfry
Stato: Non connesso
Maccanico assiduo
Maccanico assiduo
Iscritto il: lun, 16 lug 2007 17:37
Messaggi: 185

Top

Oggetto del messaggio:

Messaggio da delfry »

Se devi accedere in locale alla tua home ~lordbye/ non devi usare l'indirizzo dell airport perchè la tua home risiede in locale, e il servizio web ( che devi aver abilitato dalle preferenze di sistema - condivisione ) è attivo in locale

per accedere devi usare 127.0.0.1 che è l'idirizzo di loopback, in sostanza come url :

" http://127.0.0.1/~lordbye/ " cosi navighi su te stesso oppure " http://lnome macchina.local/~lordbye/ "


Ciao Ciao

Avatar utente
lordbye
Stato: Non connesso
Geniale
Geniale
Avatar utente
Iscritto il: mar, 11 mar 2008 12:47
Messaggi: 2058
Località: Milano - Città Studi

Top

Oggetto del messaggio:

Messaggio da lordbye »

ciao,

ho provato in entrambi i modi ma non c'era nulla da fare continuava a darmi errore alla fine ho risolto così:
1-spento apache dal pannello relativo nelle preferenze condivisione web
2- aperto il terminale
3- sono andato a /private/etc/apache2/users
4- creato con sudo un file e nominato nomeutente.conf, (c'era solo admin.conf)
5- editato il file con ilseguente testo:

CODICE
<Directory "/Users/nomeutente/Sites/">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

poi sempre da terminale ho fatto
sudo mkdir /var/log/apache2
sudo chmod 755 /var/log/apache2


una volta riavviato il web server in condivisione nelle preferenze , sono tornato in safari e ho dato

http://10.0.1.2/~lordbye/
oppure
http://127.0.0.1/~lordbye/

et voilà

"Il tuo sito web, qui e adesso.


Puoi utilizzare Condivisione Web Mac OS X per pubblicare pagine web o condividere documenti su Internet — o sul network locale di area della tua ditta o scuola — a partire da un cartella situata sul disco rigido.

Puoi scegliere tra pubblicare i tuoi documenti su Internet — o restringerne l'accesso ad alcuni utenti sulla tua rete locale. Niente di più facile, grazie alla Condivisione Web Mac OS X.

Funziona così: Crea il tuo sito web cambiando questa pagina (si chiama "index.html" e si trova nella cartella Siti della directory Inizio) e creando qualsiasi altra pagina che vuoi in formato HTML. etc............"