problemi con LibreOffice Language Pack

Mac OS X e le sue Applicazioni

Moderatore: ModiMaccanici

Avatar utente
charlie
Stato: Non connesso
Open Office Expert
Open Office Expert
Avatar utente
Iscritto il: sab, 02 mar 2013 15:04
Messaggi: 849

Top

Oggetto del messaggio: Re: problemi con LibreOffice Language Pack

Messaggio da charlie »

Ciao, per dovere di ufficio :lol: (https://forum.openoffice.org/it/forum/index.php) installo svariate versioni LibreOffice (e Open Office) sul mio mac (datato, s.o. Sierra).
Ho riscontrato anch'io il problema segnalato da Silvia e ho provato il sistema suggerito da RickS, ma neanche questo ha funzionato.
Ma ho risolto semplicemente rinominando LibreOffice 3.app (nome con il quale era archiviata la versione 7.2.1.2, ho detto che mantengo più versioni) in LibreOffice.app e la lingua italiana si è installata senza problemi, senza dover mettere il file langpack nelle Applicazioni ed espellere e cestinare alcunchè.
Per me era dunque solo un problema di riconoscimento del file.
Ergo, ciascuno trova la sua strada :wink:
RickS ha scritto:
mar, 21 set 2021 08:06
a me le ultime versioni di Libre office sono sembrate piuttosto problematiche, ho notato diversi blocchi,
È lo scotto che si paga rincorrendo sempre l'ultima versione pubblicata, è preferibile fermarsi a quella precedente che in genere è più stabile.
Charlie
iMac 27" metà 2011- SSD 525 GB - 12 GB RAM - macOS 10.12.6 Sierra

http://www.charlieopenoffice.altervista.org" onclick="window.open(this.href);return false;

Avatar utente
RickS
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: dom, 04 mag 2008 19:42
Messaggi: 895

Top

Oggetto del messaggio: Re: problemi con LibreOffice Language Pack

Messaggio da RickS »

charlie ha scritto:
mar, 21 set 2021 12:18
RickS ha scritto:
mar, 21 set 2021 08:06
a me le ultime versioni di Libre office sono sembrate piuttosto problematiche, ho notato diversi blocchi,
È lo scotto che si paga rincorrendo sempre l'ultima versione pubblicata, è preferibile fermarsi a quella precedente che in genere è più stabile.
Il tuo problema derivava dal cambiamento del nome è un BUG noto, che risalta fuori spesso, e che a seconda dei casi da anche altre noie, per regola generale con Libre Office è meglio non cambiare mai nome al programma, usa delle cartelle diverse.
Secondo me io e Silvia abbiamo avuto lo stesso problema, e non ho idea del perché sia accaduto, tra l'altro io ho sempre fatto partire il Language Pack dall'interno del suo .dmg senza alcun problema, evidentemente il Language Pack non riusciva a identificare correttamente la versione di Libre Office, ma non ho idea del perché.

Hai ragione è vero la 7.2.1 è rilasciata come "Fresh Branch", l'ultima rilasciata come "Still Branch" quindi usabile in produzione è la 7.1.6, sono stato tratto in inganno dal fatto che sulla pagina https://www.libreoffice.org/download/download/ non fosse menzionato che la 7.2.1 fosse per "sperimentatori", cose che in effetti molte volte non spcificano, quindi non ho scuse dovevo controllare :)

E comunque i problemi che sto riscontrando io e li sto riscontrando ormai da inizio 2021 quindi da almeno due o tre "Still Branch" la 7.1.6 e quella ancora precedente, che se non mi sbaglio era una 7.0.x e non sono solo a riscontrarli visto che li ho ritrovanti anche su ask.libreoffice.org e googlando un po', per fortuna ormai Libre Office lo uso davvero poco, quindi non è un grande problema.

Come mai ti tocca tenere tutte queste versioni precedenti ?
*******************************
Educazione, comprensione e pazienza sono i presupposti di comunicazione riuscita
Mai confondere l'educazione con la debolezza
In caso di emergenza chiamatemi digitando sul mio avatar il numero 555-610610

Avatar utente
Alberto.G
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: dom, 22 gen 2017 20:34
Messaggi: 1262

Top

Oggetto del messaggio: Re: problemi con LibreOffice Language Pack

Messaggio da Alberto.G »

Alberto.G ha scritto:
mar, 21 set 2021 00:44
omissis...
P.S.- Proverò domani, leggendo per bene l’articolo sul bug, se posso esserti di aiuto. Buonanotte!
Silvia, come promesso ieri notte, ho preso visione dell’articolo sul bug che avevi postato.
Purtroppo ho capito che l’articolo, salvo una decina di interventi iniziali da più persone che si lamentavano dello stesso problema, alla fine è risultato uno scambio continuo di pareri e contro pareri tra "addetti ai lavori" e/o esperti programmatori (non so di quale linguaggio) che si alternavano a dire di aver modificato questo o di aver modificato quell’altro e via dicendo.
Per la verità, dopo aver letto parecchi commenti fino ad arrivare al commento 82, non ero ancora riuscito a capire dove mettessero le mani con le loro modifiche, per cui ho lasciato perdere!
Invece, se non già fatto, ti consiglio di prendere visione degli interventi degli “Expert” RickS e charlie che entrambi hanno formulato delle soluzioni, diciamo “tampone”, per ovviare al “bug” presente da mesi sul programma di installazione del Language Pack.
Ovviamente, in attesa sempre che lo Sviluppatore metta le mani per risolvere il problema “bug”!

iMac (Retina 4K, 21.5-inch, Late 2015) Mod.16,2 - Processore 3,1 GHz Intel Core i5 (i5-5675R) CPU 4-core
Memoria 8 GB 1867 MHz DDR3 - Scheda grafica Intel Iris Pro Graphics 6200 1536 MB
sistema presente: macOS BIG SUR versione 11.6 (20G165) dal 14.09.2021 ore 07:39

ssilvia
Stato: Non connesso
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: dom, 19 set 2021 21:10
Messaggi: 7

Top

Oggetto del messaggio: Re: problemi con LibreOffice Language Pack

Messaggio da ssilvia »

Purtroppo né la soluzione di RickS né quella di Charlie funzionano nel mio caso...
Grazie Alberto per aver provato a decifrare per me le modifiche dei programmatori su bugzilla, ma mi sa che sono davvero troppo al di là della mia portata.
Alla fine ho installato la versione 7.1.6., per ora la tengo in inglese perché mi dà sempre lo stesso maledetto errore: non mi resta che attendere la risoluzione del bug nei prossimi rilasci.

Non ho risolto il problema ma sono grata dell’aiuto ricevuto e contenta che non dipendesse da una mia incapacità (non sono certo un’esperta ma tento di arrangiarmi) ma da un bug a monte. Tutto sommato un bel modo per inaugurare la mia presenza qui! :)

Avatar utente
Alberto.G
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: dom, 22 gen 2017 20:34
Messaggi: 1262

Top

Oggetto del messaggio: Re: problemi con LibreOffice Language Pack

Messaggio da Alberto.G »

Prendo atto, ma a malincuore, di quello che hai scritto.
Capisco una volta, va beh, anche una seconda volta… ma anche con la versione 7.1.6 (versione più che consolidata) hai ancora lo stesso identico errore?
A questo punto mi domando: siamo sicuri che la cosa non dipenda (anche indirettamente) dal sistema operativo che hai installato, cioè Big Sur?
Forse qualcosa che ha il tuo sistema (e che io non ho) che provoca poi quel malfunzionamento al programma di installazione del pacchetto di traduzione lingua!
Forse mi sto arrampicando sugli specchi!
Domande:
- il tuo macBook Air del 2018 funziona perfettamente?
- hai notato, magari di recente, rallentamenti o pause tra un comando ed un altro?
- si avvia regolarmente, mi riferisco ai tempi di avvio, come faceva all’inizio?
- hai in questi anni installato dei programmi di “antivirus”, o programmi che promettono pulizie accurate del disco, memoria od altro?

iMac (Retina 4K, 21.5-inch, Late 2015) Mod.16,2 - Processore 3,1 GHz Intel Core i5 (i5-5675R) CPU 4-core
Memoria 8 GB 1867 MHz DDR3 - Scheda grafica Intel Iris Pro Graphics 6200 1536 MB
sistema presente: macOS BIG SUR versione 11.6 (20G165) dal 14.09.2021 ore 07:39

Avatar utente
charlie
Stato: Non connesso
Open Office Expert
Open Office Expert
Avatar utente
Iscritto il: sab, 02 mar 2013 15:04
Messaggi: 849

Top

Oggetto del messaggio: Re: problemi con LibreOffice Language Pack

Messaggio da charlie »

Il mio consiglio è quello di installare una versione stabile come la 6.4.7.2 che uso senza probemi quando lavoro sui miei file.
La potete trovare qui, con tutti il pacchetti lingua: https://downloadarchive.documentfoundat ... ac/x86_64/
RickS ha scritto:
mar, 21 set 2021 14:30
Come mai ti tocca tenere tutte queste versioni precedenti ?
Per fornire assistenza agli utenti del forum di cui ho postato il link.
Charlie
iMac 27" metà 2011- SSD 525 GB - 12 GB RAM - macOS 10.12.6 Sierra

http://www.charlieopenoffice.altervista.org" onclick="window.open(this.href);return false;

ssilvia
Stato: Non connesso
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: dom, 19 set 2021 21:10
Messaggi: 7

Top

Oggetto del messaggio: Re: problemi con LibreOffice Language Pack

Messaggio da ssilvia »

Con la 7.1.6 stesso errore. Per il resto il macBook funziona perfettamente... Anch'io mi domando se ho qualche colpa da espiare!

Con la versione 6.4.7.2 come da ultimo suggerimento sono però finalmente riuscita a installare correttamente anche il language pack!
Evidentemente è questa la versione davvero "still", almeno per la mia macchina (chissà perché).

Avatar utente
Alberto.G
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: dom, 22 gen 2017 20:34
Messaggi: 1262

Top

Oggetto del messaggio: Re: problemi con LibreOffice Language Pack

Messaggio da Alberto.G »

Ottima conclusione!
Sono contento per te, Silvia.
In ogni caso, un sentito sincero grazie a charlie per aver dato la miglior soluzione!

iMac (Retina 4K, 21.5-inch, Late 2015) Mod.16,2 - Processore 3,1 GHz Intel Core i5 (i5-5675R) CPU 4-core
Memoria 8 GB 1867 MHz DDR3 - Scheda grafica Intel Iris Pro Graphics 6200 1536 MB
sistema presente: macOS BIG SUR versione 11.6 (20G165) dal 14.09.2021 ore 07:39