Installare programma da pacchetto tar.gz

Mac OS X e le sue Applicazioni

Moderatore: ModiMaccanici

charlie
Open Office Expert
Open Office Expert
Avatar utente
Iscritto il: sab, 02 mar 2013 15:04
Messaggi: 686
Oggetto del messaggio: Installare programma da pacchetto tar.gz

Messaggio Inviato: gio, 02 mag 2019 19:49

Ciao a tutti, volevo provare una versione di sviluppo (2.7) di Darktable che ho scaricato da qui: https://github.com/darktable-org/darkta ... ease-2.7.0.
Una volta scompattato il file, ottengo una cartella con questo contenuto:
Schermata 2019-05-02 alle 19.35.20.png
Schermata 2019-05-02 alle 19.35.20.png (21.66 KiB) Visto 572 volte
Pensavo di poterlo fare da terminale con Homebrew, ma questo continua ostinatamente ad installarmi la versione stabile del programma 2.6.2. Dove la pesca, visto che non mi chiede niente? Direttamente dal sito ufficiale? È uno strumento sbagliato per quello che mi serve fare?

Grazie.
Charlie
iMac 27" metà 2011- SSD 525 GB - 12 GB RAM - macOS 10.12.6 Sierra

http://www.charlieopenoffice.altervista.org" onclick="window.open(this.href);return false;
iStefano
Genio guastatore
Genio guastatore
Avatar utente
Iscritto il: mer, 30 dic 2009 10:30
Messaggi: 8072
Località: Pomigliano D'Arco (NA)
Contatta:

Top

Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: gio, 02 mag 2019 20:59

Read the README file and other applicable docs.
Run xmkmf -a, or the INSTALL or configure script.
Check the Makefile .
If necessary, run make clean, make Makefiles, make includes, and make depend.
Run make.
Check file permissions.
If necessary, run make install.

Scrivo su iMaccanici con TapaTalk per MacBook Air
Chappy
Maccanico Pro
Maccanico Pro
Avatar utente
Iscritto il: dom, 22 feb 2015 11:54
Messaggi: 2520
Contatta:

Top

Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: ven, 03 mag 2019 04:02

Ciao iStefano, mi permetto di tradurre il messaggio e di andare incontro al mitico charlie.
Del resto charlie mi ha sempre aiutato ed è bene offrire una mano se posso. :)

Prima di tutto, assicurati di aver compilato correttamente l'installazione di homebrew facendo riferimento a quanto postato dal nostro faxus --> http://www.imaccanici.org/forum/viewtop ... 33&t=31583

1) apri terminale e digita

Codice: Seleziona tutto

brew install git
git ti servirà per il comando git clone; riuscirai a scaricare gli script tramite terminale nel modo più sicuro.

2) torniamo nella pagina GitHub della darktable e sotto, nel pulsante verde clone or download, seleziona il collegamento url che appare, copialo.

3) in terminale incollerai questo comando:

Codice: Seleziona tutto

git clone https://github.com/darktable-org/darktable.git


attendi il termine del processo.

digita

Codice: Seleziona tutto

ls
per vedere il contenuto di home, dobbiamo ripescare ciò che ti ho fatto scaricare

...quindi spostati nella cartella darktable con il comando

Codice: Seleziona tutto

cd darktable
per mostrare il suo contenuto, di nuovo

Codice: Seleziona tutto

ls
digita ora

Codice: Seleziona tutto

git submodule init
serve per registrare il percorso di rawspeed :)

digita anche

Codice: Seleziona tutto

git submodule update
per aggiornare il modulo del programma...

...ora dobbiamo installare cmake, json-c, llvm, gcc, libjpeg, pugixml

Codice: Seleziona tutto

brew install gcc

Codice: Seleziona tutto

brew install cmake

Codice: Seleziona tutto

 brew install json-c

Codice: Seleziona tutto

brew install llvm

Codice: Seleziona tutto

brew install libjpeg

Codice: Seleziona tutto

brew install pugixml

...ora invece bisogna scaricare & installare intltool...

clicca su link blu download http, il pacchetto andrà nella cartella download.

http://www.linuxfromscratch.org/blfs/vi ... ltool.html

apri un altro terminale

Codice: Seleziona tutto

ls

Codice: Seleziona tutto

cd Downloads
oppure

Codice: Seleziona tutto

cd Scaricati

Codice: Seleziona tutto

ls

Codice: Seleziona tutto

cd intltool-0.50.2

Codice: Seleziona tutto

./configure --prefix=/usr &&
digita make

Codice: Seleziona tutto

sudo make install

questo comando ti chiedere la password, digita anche se non appare a monitor e premi invio

Codice: Seleziona tutto

brew update && brew upgrade
...procediamo con l'installazione...

Codice: Seleziona tutto

mkdir build/

Codice: Seleziona tutto

cd build/

Codice: Seleziona tutto

cmake -DCMAKE_INSTALL_PREFIX=/opt/darktable/ ..
facci sapere quali errori ti darà il terminale.
Continueremo insieme con altri informatici, ci sono diverse librerie da sistemare ed è ancora in fase di sviluppo, ci sono errori da risolvere...
"L'espressione migliore di educazione è quella di correggere in privato e congratulare in pubblico."
charlie
Open Office Expert
Open Office Expert
Avatar utente
Iscritto il: sab, 02 mar 2013 15:04
Messaggi: 686
Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: ven, 03 mag 2019 09:16

Chappy ha scritto:
ven, 03 mag 2019 04:02
... e di andare incontro al mitico charlie.
Del resto charlie mi ha sempre aiutato ed è bene offrire una mano se posso.
Ti sono grato, anche se non ricordo di averti aiutato. Difficile sia potuto accadere qui, forse altrove? :)

Ho per ora letto attentamente le tue istruzioni e penso di essere in grado di eseguirle, tanto sono chiare e lineari !
Per ora una domanda: siamo sicuri che la versione di darktable che andremo ad installare è quella di sviluppo 2.7.0?
Non vorrei ritrovarmi con la versione stabile 2.6.2 che uso già da tempo e che le mie prove (inesperte) con Homebrew mi hanno fatto re-installare più volte.
Grazie.
Charlie
iMac 27" metà 2011- SSD 525 GB - 12 GB RAM - macOS 10.12.6 Sierra

http://www.charlieopenoffice.altervista.org" onclick="window.open(this.href);return false;
Chappy
Maccanico Pro
Maccanico Pro
Avatar utente
Iscritto il: dom, 22 feb 2015 11:54
Messaggi: 2520
Contatta:

Top

Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: ven, 03 mag 2019 14:13

Stop, stop..

È la versione 2.6 scusami! Era notte fonda e non ci avevo badato attentamente.

Appena posso vado ad analizzare il tuo link con la 2.7
"L'espressione migliore di educazione è quella di correggere in privato e congratulare in pubblico."
faxus
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 26207
Località: Due Sicilie
Contatta:

Top

Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: ven, 03 mag 2019 14:25

Chappy ha scritto:
ven, 03 mag 2019 04:02
... git ti servirà per il comando git clone...
Ottimo.

Mi farà piacere leggere questo contributo nel topic di brew.
Ma anche, se preferisci, come tutorial a sé stante.
Così potrà essere citato facilmente per chi lo chieda.

Ovviamente fallo tu.
Ci ho pensato varie volte.
Una volta lo chiedete specificatamente anche Kernel Panic.

Ma siccome non lo usa mai, per pigrizia...
Per pigrizia non l'ho mai scritto
faxus
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 26207
Località: Due Sicilie
Contatta:

Top

Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: ven, 03 mag 2019 14:27

Stephane De la Palisse ha scritto:
gio, 02 mag 2019 20:59
Read the README...
Kernel Panic
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 25236
Località: Sicilia
Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: ven, 03 mag 2019 21:06

faxus ha scritto:
ven, 03 mag 2019 14:25
.... Una volta lo chiedete specificatamente anche Kernel Panic.

Ma siccome non lo usa mai, per pigrizia.....
Davvero lo chiedetti?
Non me lo ricordo proprio .....
fragrua
Admin of my life
Admin of my life
Avatar utente
Iscritto il: sab, 08 ott 2005 07:00
Messaggi: 56202
Località: [k]issà
Contatta:

Top

Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: ven, 03 mag 2019 21:20

Kernel Panic ha scritto:
ven, 03 mag 2019 21:06
faxus ha scritto:
ven, 03 mag 2019 14:25
.... Una volta lo chiedete specificatamente anche Kernel Panic.

Ma siccome non lo usa mai, per pigrizia.....
Davvero lo chiedetti?
Non me lo ricordo proprio .....
Dopo quello che Faxus sta passando (nella vita reale, e un po' anche qui) permettiamogli un refuso. ;-)
La prima cosa su cui devi investire è il benessere del tuo corpo, l'unica cosa che ti porterai nella tomba.
Franz Grua (sarebbe fragrua)

In un mondo perfetto io sarei un essere inutile.
©2015 albertocchio

—> Uso corretto del Forum: https://goo.gl/9xOO0a

Immagine
faxus
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 26207
Località: Due Sicilie
Contatta:

Top

Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: ven, 03 mag 2019 22:48

Kernel Panic ha scritto:
ven, 03 mag 2019 21:06
... Davvero lo chiedetti?...
Hah, chissà come mi volevo esprimere, poi il correttore avrà messo del suo...

Sì, comunque.
Tu una volta hai chiesto qualcosa in merito.
Era una discussione in cui discutevamo su Macupdate che posta già compilati i pacchetti di GitHub.

O giù di lì.
Ma qualsiasi cosa fosse non era una critica
faxus
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 26207
Località: Due Sicilie
Contatta:

Top

Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: ven, 03 mag 2019 22:50

fragrua ha scritto:
ven, 03 mag 2019 21:20
... Dopo quello che Faxus sta passando...
Grazie, amico mio.

Ma non succederà nulla.
Sono più duro di un pavesino (biscotto)
Kernel Panic
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 25236
Località: Sicilia
Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: sab, 04 mag 2019 02:09

faxus ha scritto:
ven, 03 mag 2019 22:48
..... Ma qualsiasi cosa fosse non era una critica
Ma lo so, ovviamente scherzavo ..... :)
charlie
Open Office Expert
Open Office Expert
Avatar utente
Iscritto il: sab, 02 mar 2013 15:04
Messaggi: 686
Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: sab, 04 mag 2019 09:36

Chappy ha scritto:
ven, 03 mag 2019 14:13
Stop, stop..

È la versione 2.6 scusami! Era notte fonda e non ci avevo badato attentamente.

Appena posso vado ad analizzare il tuo link con la 2.7
Scusami, non ho avuto pazienza.
Sono andato avanti sostituendo con copia/incolla il contenuto della cartella darktable, che mi avevi fatto scaricare con il comando

Codice: Seleziona tutto

 git clone https://github.com/darktable-org/darktable.git

con il contenuto della cartella scompattata della versione 2.7.0.

È andato tutto bene fino al comando

Codice: Seleziona tutto

sudo make install
Ecco gli errori che ne sono usciti andando avanti fino in fondo:

Codice: Seleziona tutto

iMac-di-mac:intltool-0.50.2 mac$ ./configure --prefix=/usr &&
> sudo make install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.18.2
checking for XML::Parser... ok
checking for bzr... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating doc/Makefile
config.status: creating intltoolize
config.status: creating tests/Makefile
config.status: creating tests/cases/Makefile
config.status: creating tests/results/Makefile
config.status: creating tests/selftest.pl
Password:
Making install in tests
Making install in cases
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in results
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in doc
make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/share/man/man8" || .././install-sh -c -d "/usr/share/man/man8"
 /usr/bin/install -c -m 644 intltoolize.8 intltool-extract.8 intltool-merge.8 intltool-prepare.8 intltool-update.8 '/usr/share/man/man8'
sed -e 's|[@]PACKAGE@|intltool|g' -e 's|[@]VERSION@|0.50.2|g' -e "s|[@]INTLTOOL_PERL@|/usr/bin/perl|g" -e "s|[@]INTLTOOL_LIBDIR@|/usr/lib|g" < intltool-extract.in > intltool-extract
chmod +x intltool-extract
sed -e 's|[@]PACKAGE@|intltool|g' -e 's|[@]VERSION@|0.50.2|g' -e "s|[@]INTLTOOL_PERL@|/usr/bin/perl|g" -e "s|[@]INTLTOOL_LIBDIR@|/usr/lib|g" < intltool-merge.in > intltool-merge
chmod +x intltool-merge
sed -e 's|[@]PACKAGE@|intltool|g' -e 's|[@]VERSION@|0.50.2|g' -e "s|[@]INTLTOOL_PERL@|/usr/bin/perl|g" -e "s|[@]INTLTOOL_LIBDIR@|/usr/lib|g" < intltool-update.in > intltool-update
chmod +x intltool-update
sed -e 's|[@]PACKAGE@|intltool|g' -e 's|[@]VERSION@|0.50.2|g' -e "s|[@]INTLTOOL_PERL@|/usr/bin/perl|g" -e "s|[@]INTLTOOL_LIBDIR@|/usr/lib|g" < intltool-prepare.in > intltool-prepare
chmod +x intltool-prepare
test -z "/usr/bin" || ./install-sh -c -d "/usr/bin"
 /usr/bin/install -c intltool-extract intltool-merge intltool-update intltoolize intltool-prepare '/usr/bin'
install: /usr/bin/intltool-extract: Operation not permitted
make[2]: *** [install-binSCRIPTS] Error 71
make[1]: *** [install-am] Error 2
make: *** [install-recursive] Error 1
iMac-di-mac:intltool-0.50.2 mac$

iMac-di-mac:intltool-0.50.2 mac$ brew update && brew upgrade
Already up-to-date.
iMac-di-mac:intltool-0.50.2 mac$

iMac-di-mac:intltool-0.50.2 mac$ mkdir build/
iMac-di-mac:intltool-0.50.2 mac$ 

iMac-di-mac:intltool-0.50.2 mac$ cd build/
iMac-di-mac:build mac$ 

iMac-di-mac:build mac$ cmake -DCMAKE_INSTALL_PREFIX=/opt/darktable/ ..
CMake Error: The source directory "/Users/mac/downloads/intltool-0.50.2" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
iMac-di-mac:build mac$  
Charlie
iMac 27" metà 2011- SSD 525 GB - 12 GB RAM - macOS 10.12.6 Sierra

http://www.charlieopenoffice.altervista.org" onclick="window.open(this.href);return false;
Chappy
Maccanico Pro
Maccanico Pro
Avatar utente
Iscritto il: dom, 22 feb 2015 11:54
Messaggi: 2520
Contatta:

Top

Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: sab, 04 mag 2019 18:50

Ci sono una marea di errori, vediamo di risolverli insieme, facciamo ordine

Prima di tutto dobbiamo installare correttamente llvm & clang, sono dipendenze importanti di darktable.

Prima di installare llvm, bisogna aggiungere una chiave per la sua libreria.

apri terminale e digita

Codice: Seleziona tutto

wget -O - http://apt.llvm.org/llvm-snapshot.gpg.key
poi

Codice: Seleziona tutto

sudo ssh-add -K percorsodicharlie/llvm-snapshot.gpg.key
al posto di percorsodicharlie devi indicare il tuo path, trascina semplicemente llvm-snapshot.gpg.key in terminale e
sarà calcolato automaticamente il percorso.

Se tutto andrà bene, ti apparirà questo messaggio

Codice: Seleziona tutto

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@         WARNING: UNPROTECTED PRIVATE KEY FILE!          @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
Permissions 0644 for '/Users/Casper/Desktop/llvm-snapshot.gpg.key' are too open.
It is required that your private key files are NOT accessible by others.
This private key will be ignored.
per confermare, digita

Codice: Seleziona tutto

sudo ssh-add
ora installiamo llvm

Codice: Seleziona tutto

brew install llvm
passiamo a clang, prima di clang bisogna sistemare head

Codice: Seleziona tutto

brew unlink isl
questo comando serve per lasciare campo aperto all'installazione di head

seguirà una sequenza di errori come

Codice: Seleziona tutto

Error: An exception occurred within a child process:
  RuntimeError: /usr/local/opt/autoconf not present or broken
Please reinstall autoconf. Sorry :(
procedi con

Codice: Seleziona tutto

brew reinstall autoconf
applica gli effetti con

Codice: Seleziona tutto

brew reinstall
procedi con

Codice: Seleziona tutto

brew reinstall automake
applica gli effetti con

Codice: Seleziona tutto

brew reinstall
procedi con

Codice: Seleziona tutto

brew reinstall libtool
applica gli effetti con

Codice: Seleziona tutto

brew reinstall
installa head con questo comando

Codice: Seleziona tutto

brew install isl --HEAD
installiamo php

Codice: Seleziona tutto

curl -s http://php-osx.liip.ch/install.sh | bash -s 7.2

Codice: Seleziona tutto

curl -s https://php-osx.liip.ch/install.sh | bash -s force 7.2
installa composer

Codice: Seleziona tutto

brew install composer
php e composer sono altre dipendenze importanti.

verifica l'installazione di llvm e clang con

Codice: Seleziona tutto

clang --version
se tutto è andato bene vedrai

Codice: Seleziona tutto

Apple LLVM version 10.0.1 (clang-1001.0.46.4)
Target: x86_64-apple-darwin18.5.0
Thread model: posix
InstalledDir: /Library/Developer/CommandLineTools/usr/bin
installa darktable 2.7

1) vai sul link che ci hai condiviso https://github.com/darktable-org/darkta ... ease-2.7.0

2) seleziona source code (tar.gz)

Apri terminale

Codice: Seleziona tutto

cd Downloads
oppure

Codice: Seleziona tutto

cd Scaricati
per visualizzare il contenuto

Codice: Seleziona tutto

ls
procedi con l'installazione

Codice: Seleziona tutto

tar -zxvf darktable-release-2.7.0.tar.gz

Codice: Seleziona tutto

cd darktable-release-2.7.0 

Codice: Seleziona tutto

ls

Codice: Seleziona tutto

sudo bash build.sh
Riporta eventuali errori qui
"L'espressione migliore di educazione è quella di correggere in privato e congratulare in pubblico."
charlie
Open Office Expert
Open Office Expert
Avatar utente
Iscritto il: sab, 02 mar 2013 15:04
Messaggi: 686
Oggetto del messaggio: Re: Installare programma da pacchetto tar.gz

Messaggio Inviato: sab, 04 mag 2019 19:13

Grazie infinite, ti saprò dire.
Chappy ha scritto:
sab, 04 mag 2019 18:50
Prima di installare llvm, bisogna aggiungere una chiave per la sua libreria.
Lo avevamo già installato, bisogna disinstallarlo?
Charlie
iMac 27" metà 2011- SSD 525 GB - 12 GB RAM - macOS 10.12.6 Sierra

http://www.charlieopenoffice.altervista.org" onclick="window.open(this.href);return false;
Rispondi