Pop-up noioso mi chiede di installare il runtime Java SE 6 legacy

macOS Mojave (versione 10.14) è la quindicesima versione del sistema operativo macOS sviluppato da Apple .
Include subforum per le versioni precedenti di macOS e OS X.

Moderatore: ModiMaccanici

Avatar utente
jarulex
Stato: Non connesso
Maccanico attivo
Maccanico attivo
Avatar utente
Iscritto il: lun, 03 dic 2007 09:59
Messaggi: 294
Località: Monaco

Top

Salve Maccanici
ogni volta che accendo il Mac anche con Mojave mi appare questo popup (vedi foto) che mi invita a installare runtime Java ecc.
Mi trascino questo popup da anni.
Cliccare su ‘Ulteriori informazioni’ e scaricare ancora una volta Java non risolve nulla.
Come posso eliminarlo?
Grazie.
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.

Avatar utente
Paolofast
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 3039

Top

Oggetto del messaggio: Re: un popup noioso

Messaggio da Paolofast »

Software vecchi e/o mal scritti, richiedono obbligatoriamente la presenza di un java marcato Apple.
Che trovi qui:

https://support.apple.com/kb/DL1572?vie ... cale=it_IT

Una volta installato non apparirà più il popup.
Curiosamente, nella maggior parte dei casi, il software incriminato, una volta verificata la presenza del java "apple", userà tranquillamente l'ultima versione Oracle.
Se installando Yosemite, El Capitan, Sierra, High Sierra, Mojave o Catalina, il Mac vi dice che l'installer è danneggiato, non è danneggiato, ha il certificato scaduto. Leggete qui:
viewtopic.php?f=33&t=46076
In pratica o scarichi l'installer aggiornato o modifichi la data nell'orologio del Mac.

Avatar utente
Kernel Panic
Stato: Non connesso
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 26751
Località: Sicilia

Top

Oggetto del messaggio: Re: un popup noioso

Messaggio da Kernel Panic »

Modificherei il titolo in "Pop-up noioso mi chiede di installare il runtime Java SE 6 legacy " affinché rispecchi il contenuto del topic.

Immagine

Avatar utente
faxus
Stato: Non connesso
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 28936
Località: Circondato dalle bufale

Top

Oggetto del messaggio: Re: un popup noioso

Messaggio da faxus »

Non si deve usare Java nelle versioni inferiori al 8.
(che peraltro sta per essere dichiarata non più supportata a giorni).

Chi ha necessità deve usare una JDK.
Il pacchetto completo di sviluppo è Legacy.
Cioè comprende i codici sorgenti delle versioni dalla 6 in poi.
Ha lo scopo di preservare le funzionalità supportate in precedenza

Questa versione è quella attuale JDK con le funzionalità dette
viewtopic.php?f=5&t=19867&p=488018#p488018

Avatar utente
Paolofast
Stato: Non connesso
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 3039

Top

Purtroppo programmi vecchi e/o scritti male continuano a rompere gli … elettroni se non trovano la vecchia versione legacy di Apple.
Poi non la usano, usano quella nuova, ma la vogliono presente.
Così, per dare fastidio.
Se installando Yosemite, El Capitan, Sierra, High Sierra, Mojave o Catalina, il Mac vi dice che l'installer è danneggiato, non è danneggiato, ha il certificato scaduto. Leggete qui:
viewtopic.php?f=33&t=46076
In pratica o scarichi l'installer aggiornato o modifichi la data nell'orologio del Mac.