10.9.2 non funziona più la videocamera [risolto]

Tutto quello che riguarda OS X Mavericks 10.9

Moderatore: ModiMaccanici

bugsbunny
Maccanico assiduo
Maccanico assiduo
Iscritto il: dom, 20 nov 2011 00:06
Messaggi: 132
Oggetto del messaggio: 10.9.2 non funziona più la videocamera [risolto]

Messaggio Inviato: ven, 28 feb 2014 18:57

Salve,

è capitato a qualcuno? Dopo l'aggiornamento 10.9.2 su MacBookPro Mid/Late 2007 non funziona più la videocamera integrata. Non la vede proprio!

Il terminale continua a dare questo messaggio:
28/02/14 18:52:45,907 ReportCrash[1224]: Saved crash report for VDCAssistant[2781] version 4561 to /Library/Logs/DiagnosticReports/VDCAssistant_2014-02-28-185245-1_BomboMacBook.crash
28/02/14 18:52:46,423 com.apple.launchd[1]: (com.apple.cmio.VDCAssistant[2782]) Job appears to have crashed: Abort trap: 6
28/02/14 18:52:46,486 VDCAssistant[2783]: AVF error: AVDLoadAllAccelerators machine not supported
28/02/14 18:52:46,488 VDCAssistant[2783]: AVF warning: failed to get a service for display id: 4128828
28/02/14 18:52:46,488 VDCAssistant[2783]: AVF warning: failed to get a service for display id: 4128829
28/02/14 18:52:46,488 VDCAssistant[2783]: AVF warning: failed to get a service for display id: 4128830
28/02/14 18:52:46,488 VDCAssistant[2783]: AVF warning: failed to get a service for display id: 4128832
28/02/14 18:52:46,489 VDCAssistant[2783]: AVF warning: failed to get a service for display id: 4128831
28/02/14 18:52:46,505 VDCAssistant[2783]: CGSDisplayID: App trying to enumerate [0 to CGSGetNumberOfDisplays()] instead of using CGSGetDisplayList(). Compensating...
28/02/14 18:52:46,505 VDCAssistant[2783]: Client is attempting to access a display by index (5) instead of display ID.

Qualcuno sa cosa fare?

Grazie
 iMac 20" metà 2007 OS X 10.9  iMac 21,5" Mid 2010 OS X 10.9  MacBook Pro 15" Mid/late 2007 2.2 GHz OS X 10.9  Time Capsule 2TB  Airport Express  iPad 2 64GB  iPhone 5S 16GB  iCharger 
Kernel Panic
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 25743
Località: Sicilia
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: ven, 28 feb 2014 19:10

bugsbunny ha scritto: …. Dopo l'aggiornamento 10.9.2 su MacBookPro Mid/Late 2007 non funziona più la videocamera integrata. Non la vede proprio!
Prova questo: http://support.apple.com/kb/HT1379?viewlocale=it_IT" onclick="window.open(this.href);return false;
Zen
Unix Expert
Unix Expert
Avatar utente
Iscritto il: sab, 14 gen 2012 01:24
Messaggi: 2435
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: ven, 28 feb 2014 19:32

Qualcuno ha risolto rimuovendo Airdisplay/Airparrot (o software simili).
bugsbunny
Maccanico assiduo
Maccanico assiduo
Iscritto il: dom, 20 nov 2011 00:06
Messaggi: 132
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: ven, 28 feb 2014 20:22

Kernel Panic ha scritto: Prova questo: http://support.apple.com/kb/HT1379?viewlocale=it_IT" onclick="window.open(this.href);return false;
fatto il reset PRAM, ma purtroppo non cambia nulla! :(
 iMac 20" metà 2007 OS X 10.9  iMac 21,5" Mid 2010 OS X 10.9  MacBook Pro 15" Mid/late 2007 2.2 GHz OS X 10.9  Time Capsule 2TB  Airport Express  iPad 2 64GB  iPhone 5S 16GB  iCharger 
bugsbunny
Maccanico assiduo
Maccanico assiduo
Iscritto il: dom, 20 nov 2011 00:06
Messaggi: 132
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: ven, 28 feb 2014 20:28

Zen ha scritto:Qualcuno ha risolto rimuovendo Airdisplay/Airparrot (o software simili).

Ho visto anche io su un sito USA, ma non ho installato software simili.

Mi tocca aspettare un altro aggiornamento? Non è possibile eliminare l'aggiornamento? fino alla 10.9.1 problemi non ne avevo :( :banghead:
 iMac 20" metà 2007 OS X 10.9  iMac 21,5" Mid 2010 OS X 10.9  MacBook Pro 15" Mid/late 2007 2.2 GHz OS X 10.9  Time Capsule 2TB  Airport Express  iPad 2 64GB  iPhone 5S 16GB  iCharger 
Zen
Unix Expert
Unix Expert
Avatar utente
Iscritto il: sab, 14 gen 2012 01:24
Messaggi: 2435
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: ven, 28 feb 2014 21:19

Mi tocca aspettare un altro aggiornamento? Non è possibile eliminare l'aggiornamento? fino alla 10.9.1 problemi non ne avevo :( :banghead:
Non sembra sia l'aggiornamento di OS X il problema, ma piuttosto qualche app che non è stata aggiornata e crea problemi.
Comunque no, non è possibile disinstallare una aggiornamento. Si può solo reinstallare il sistema, ma comunque sia tornare alla 10.9.1 è una follia perché la 10.9.2 chiude il bug di sicurezza della connessioni criptate.

Proviamo ad indagare: copia e incolla nel terminale questo comando e posta il risultato nei tag code.

Codice: Seleziona tutto

ls -1 /Library/Launch* ~/Library/Launch* /Library/Extensions/
bugsbunny
Maccanico assiduo
Maccanico assiduo
Iscritto il: dom, 20 nov 2011 00:06
Messaggi: 132
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: sab, 01 mar 2014 13:38

Zen ha scritto:
Mi tocca aspettare un altro aggiornamento? Non è possibile eliminare l'aggiornamento? fino alla 10.9.1 problemi non ne avevo :( :banghead:
Non sembra sia l'aggiornamento di OS X il problema, ma piuttosto qualche app che non è stata aggiornata e crea problemi.
Comunque no, non è possibile disinstallare una aggiornamento. Si può solo reinstallare il sistema, ma comunque sia tornare alla 10.9.1 è una follia perché la 10.9.2 chiude il bug di sicurezza della connessioni criptate.

Proviamo ad indagare: copia e incolla nel terminale questo comando e posta il risultato nei tag code.

Codice: Seleziona tutto

ls -1 /Library/Launch* ~/Library/Launch* /Library/Extensions/
ok questo è il risultato!

Codice: Seleziona tutto

ls -1 /Library/Launch* ~/Library/Launch* /Library/Extensions/
/Library/Extensions/:
APExtFramebuffer.kext
ATTOCelerityFC8.kext
ATTOExpressSASHBA2.kext
ATTOExpressSASRAID2.kext
AirParrotDriver.kext
ArcMSR.kext
CalDigitHDProDrv.kext
HighPointIOP.kext
HighPointRR.kext
PromiseSTEX.kext
SoftRAID.kext

/Library/LaunchAgents:
com.adobe.AAM.Updater-1.0.plist
com.google.keystone.agent.plist
com.oracle.java.Java-Updater.plist
com.teamviewer.teamviewer.plist
com.teamviewer.teamviewer_desktop.plist
de.novamedia.VodafoneDeviceObserver.plist
org.macosforge.xquartz.startx.plist

/Library/LaunchDaemons:
com.adobe.fpsaud.plist
com.bombich.ccc.plist
com.cleverfiles.cfbackd.plist
com.freemacsoft.appcleanerd.plist
com.google.keystone.daemon.plist
com.oracle.java.Helper-Tool.plist
com.oracle.java.JavaUpdateHelper.plist
com.teamviewer.teamviewer_service.plist
it.fub.nemesys.plist
org.macosforge.xquartz.privileged_startx.plist

/Users/marcobombonato/Library/LaunchAgents:
com.adobe.ARM.ad895013aeb33ea6e968d9fdc06c0eb42c7c2a5229d98d64ad002716.plist
com.adobe.ARM.c0710a3bbc1f7b43a9487efa35b9142c1acc4fbd27f79fa7f26c3632.plist
com.apple.SafariBookmarksSyncer.plist
BomboMacBook:~ marcobombonato$ 
 iMac 20" metà 2007 OS X 10.9  iMac 21,5" Mid 2010 OS X 10.9  MacBook Pro 15" Mid/late 2007 2.2 GHz OS X 10.9  Time Capsule 2TB  Airport Express  iPad 2 64GB  iPhone 5S 16GB  iCharger 
Zen
Unix Expert
Unix Expert
Avatar utente
Iscritto il: sab, 14 gen 2012 01:24
Messaggi: 2435
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: sab, 01 mar 2014 14:05

La kext (simile ai driver per Windows) APExtFramebuffer.kext appartiene ad Airparrot...

Vediamo di rimuoverla: dai il seguente comando. Ti chiederà la password, ma non comparirà. Digitala lo stesso e quando hai finito dai invio e poi riavvia.

Codice: Seleziona tutto

sudo rm -rf /Library/Extensions/APExtFramebuffer.kext
Dovrebbe tornare a funzionare.
bugsbunny
Maccanico assiduo
Maccanico assiduo
Iscritto il: dom, 20 nov 2011 00:06
Messaggi: 132
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: sab, 01 mar 2014 14:29

Zen ha scritto:La kext (simile ai driver per Windows) APExtFramebuffer.kext appartiene ad Airparrot...

Vediamo di rimuoverla: dai il seguente comando. Ti chiederà la password, ma non comparirà. Digitala lo stesso e quando hai finito dai invio e poi riavvia.

Codice: Seleziona tutto

sudo rm -rf /Library/Extensions/APExtFramebuffer.kext
Dovrebbe tornare a funzionare.
Ho fatto come mi hai detto (grazie). Riavviato e poi per provare la videocamera ho avviato skype. Niente non funziona ancora. La console riporta il medesimo messaggio che continua a reiterare (occupando parecchia CPU).

Se può essere utile ho fatto lo stesso aggiornamento (10.9.2) su iMac mid 2010 senza avere nessun problema la videocamera e skype funzionano perfettamente.

Hai altre idee?
 iMac 20" metà 2007 OS X 10.9  iMac 21,5" Mid 2010 OS X 10.9  MacBook Pro 15" Mid/late 2007 2.2 GHz OS X 10.9  Time Capsule 2TB  Airport Express  iPad 2 64GB  iPhone 5S 16GB  iCharger 
Zen
Unix Expert
Unix Expert
Avatar utente
Iscritto il: sab, 14 gen 2012 01:24
Messaggi: 2435
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: sab, 01 mar 2014 14:32

Ho avuto una svista e ho perso l'altra kext (ce ne sono 2):

Codice: Seleziona tutto

sudo rm -rf /Library/Extensions/AirParrotDriver.kext
Stesso discorso di prima.
bugsbunny
Maccanico assiduo
Maccanico assiduo
Iscritto il: dom, 20 nov 2011 00:06
Messaggi: 132
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: sab, 01 mar 2014 14:33

INFO AGGIUNTIVE

Ho riprovato a dare il comando che mi hai suggerito:

ls -1 /Library/Launch* ~/Library/Launch* /Library/Extensions/

nell'output compare di nuovo:

AirParrotDriver.kext

Forse la cancellazione non è andata a buon fine? Oppure il processo si riavvia in automatico?
 iMac 20" metà 2007 OS X 10.9  iMac 21,5" Mid 2010 OS X 10.9  MacBook Pro 15" Mid/late 2007 2.2 GHz OS X 10.9  Time Capsule 2TB  Airport Express  iPad 2 64GB  iPhone 5S 16GB  iCharger 
bugsbunny
Maccanico assiduo
Maccanico assiduo
Iscritto il: dom, 20 nov 2011 00:06
Messaggi: 132
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: sab, 01 mar 2014 14:33

OK provvedo
 iMac 20" metà 2007 OS X 10.9  iMac 21,5" Mid 2010 OS X 10.9  MacBook Pro 15" Mid/late 2007 2.2 GHz OS X 10.9  Time Capsule 2TB  Airport Express  iPad 2 64GB  iPhone 5S 16GB  iCharger 
bugsbunny
Maccanico assiduo
Maccanico assiduo
Iscritto il: dom, 20 nov 2011 00:06
Messaggi: 132
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: sab, 01 mar 2014 14:56

NEGATIVO :(

questo è quanto riporta il terminale

Codice: Seleziona tutto

ATTOCelerityFC8.kext
ATTOExpressSASHBA2.kext
ATTOExpressSASRAID2.kext
ArcMSR.kext
CalDigitHDProDrv.kext
HighPointIOP.kext
HighPointRR.kext
PromiseSTEX.kext
SoftRAID.kext

/Library/LaunchAgents:
com.adobe.AAM.Updater-1.0.plist
com.google.keystone.agent.plist
com.oracle.java.Java-Updater.plist
com.teamviewer.teamviewer.plist
com.teamviewer.teamviewer_desktop.plist
de.novamedia.VodafoneDeviceObserver.plist
org.macosforge.xquartz.startx.plist

/Library/LaunchDaemons:
com.adobe.fpsaud.plist
com.bombich.ccc.plist
com.cleverfiles.cfbackd.plist
com.freemacsoft.appcleanerd.plist
com.google.keystone.daemon.plist
com.oracle.java.Helper-Tool.plist
com.oracle.java.JavaUpdateHelper.plist
com.teamviewer.teamviewer_service.plist
it.fub.nemesys.plist
org.macosforge.xquartz.privileged_startx.plist

/Users/marcobombonato/Library/LaunchAgents:
com.adobe.ARM.ad895013aeb33ea6e968d9fdc06c0eb42c7c2a5229d98d64ad002716.plist
com.adobe.ARM.c0710a3bbc1f7b43a9487efa35b9142c1acc4fbd27f79fa7f26c3632.plist
com.apple.SafariBookmarksSyncer.plist
BomboMacBook:~ marcobombonato$ 
 iMac 20" metà 2007 OS X 10.9  iMac 21,5" Mid 2010 OS X 10.9  MacBook Pro 15" Mid/late 2007 2.2 GHz OS X 10.9  Time Capsule 2TB  Airport Express  iPad 2 64GB  iPhone 5S 16GB  iCharger 
Zen
Unix Expert
Unix Expert
Avatar utente
Iscritto il: sab, 14 gen 2012 01:24
Messaggi: 2435
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: sab, 01 mar 2014 15:46

Avevi riavviato?
Più che altro perché ormai non ci dovrebbe essere niente o quasi che interferisca con AVF.
bugsbunny
Maccanico assiduo
Maccanico assiduo
Iscritto il: dom, 20 nov 2011 00:06
Messaggi: 132
Oggetto del messaggio: Re: 10.9.2 non mi funziona più la videocamera

Messaggio Inviato: sab, 01 mar 2014 17:10

Zen ha scritto:Avevi riavviato?
Si certo! Parte correttamente, non appena avvio Skype o Photo Booth (programmi che cercano la videocamera) immediatamente sulla console vedo partire la sequenza (che ho allegato nel primo messaggio) e ovviamente la macchina rallenta.

Da notare che con 10.9.2 sull'iMac questa volta, anche l'icona di dropbox fa delle stravaganze. Dropbox funziona lo vedo con finder ma l'icona che si trova di solito nella barra strumenti compare all'avvio e poi scompare. Non c'entra nulla con la webcam ma tanto per gradire... Problema che non succede su MacBookPro....
 iMac 20" metà 2007 OS X 10.9  iMac 21,5" Mid 2010 OS X 10.9  MacBook Pro 15" Mid/late 2007 2.2 GHz OS X 10.9  Time Capsule 2TB  Airport Express  iPad 2 64GB  iPhone 5S 16GB  iCharger 
Rispondi