Upgrade openssl su MacosXLion server

Le vostre creatività migliori

Moderatori: Gattinara, ModiMaccanici

Rispondi
gioMaccanici
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mar, 07 feb 2017 11:49
Messaggi: 2
Oggetto del messaggio: Upgrade openssl su MacosXLion server

Messaggio Inviato: mar, 07 feb 2017 12:31

salve a tutti

sto cercando di installare openssl 1.0.2k su un mac con osx lion server
con brew sono riuscito a installare openSSl
adesso infatti se chiedo la versione di openssl mi risponde così

gio:1.0.2k lionserver$ openssl version
OpenSSL 1.0.2k 26 Jan 2017

il server apache invece continua a rispondere con la vecchia versione di openssl 0.9.8


Apache/2.2.26 (Unix) PHP/5.5.38 mod_ssl/2.2.26 OpenSSL/0.9.8za DAV/2 Server at http://www.cipeciop.it" onclick="window.open(this.href);return false; Port 80

come posso uniformare le due cose?
su quali file devo andare a mettere mano?

secondo voi é possibile installare php 5.6 e mysql server 5.6 su macosx Lion server?

se si partendo da dove?

TIA

Giovanni
faxus
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 26256
Località: Due Sicilie
Contatta:

Top

Oggetto del messaggio: Re: Upgrade openssl su MacosXLion server

Messaggio Inviato: mar, 07 feb 2017 12:57

Benvenuto.

Se vuoi presentarti alla comunità puoi farlo da
viewforum.php?f=30" onclick="window.open(this.href);return false;
Saremo in tanti a salutarti.

Per il resto:

- Versioni di software inserito nel sistema e implementate sul sistema, che differiscono dalla versione preinstallata, vengono installate in versione keg only.
Dedicate alla sola funzione di supportare le applicazioni installate dall'utente che lo richiedono.
Nessun problema, quindi, e soprattutto non devi assolutamente cercare di uniformare nulla.
Tra l'altro, attualmente, non potresti farlo.

La cosa viene descritta anche nell'apposito topic su Brew
viewtopic.php?f=33&t=31583" onclick="window.open(this.href);return false;

Per le versioni di MySQL e Php installabili su 10.7 server mi sembra che quelle indicate siano possibili.
Ma non ti resta che andare sui siti di riferimento e controllare sulle caratteristiche richieste dalla versione.

Se vuoi spiegare perché ti serva implementare tutto questo software, forse si potrebbe analizzare la situazione.
Per esempio, usare un pacchetto precompilato pronto, tipo MAMP, potrebbe essere più agevole?
gioMaccanici
Nuovo Maccanico
Nuovo Maccanico
Iscritto il: mar, 07 feb 2017 11:49
Messaggi: 2
Oggetto del messaggio: Re: Upgrade openssl su MacosXLion server

Messaggio Inviato: mar, 07 feb 2017 16:12

l'istallazione di tutto questo software mi serve per un sito in wordpress che ha un collegamento con una banca che richiede l'https e openssl minimo 1.0.1

ho provato mamp 3.5.2

ma non mi cambia la versione di openssl lasciandola a 0.9.8zh
e il server mysql è 5.5.42 e non 5.6

secondo te sono aggiornabili separatamente?
istallando mamp su un server già configurato con diversi siti gia istallati anche con mysql potrebbe provocare cancellazioni o non funzionamenti?

le versioni che mi hanno richiesto sono come minimo

php e mysql 5.6
openssl 1.0.1

TIA
Giovanni
faxus
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 26256
Località: Due Sicilie
Contatta:

Top

Oggetto del messaggio: Re: Upgrade openssl su MacosXLion server

Messaggio Inviato: mar, 07 feb 2017 18:56

gioMaccanici ha scritto:l'istallazione di tutto questo software mi serve per un sito in wordpress che ha un collegamento con una banca che richiede l'https...
Https è ormai indispensabile per qualsiasi sito che richieda password per conti e carte di credito.
In ogni caso per qualsiasi operazione che consenta transazioni in denaro.

Altrimenti, oltre la richiesta ovvia della banca, sarà vietato in navigazione da Chrome e Firefox.
E tra breve da tutti
gioMaccanici ha scritto:... ho provato mamp 3.5.2
ma non mi cambia la versione di openssl lasciandola a 0.9.8zh
e il server mysql è 5.5.42 e non 5.6
secondo te sono aggiornabili separatamente?
istallando mamp su un server già configurato con diversi siti gia istallati anche con mysql potrebbe provocare cancellazioni o non funzionamenti?

le versioni che mi hanno richiesto sono come minimo
php e mysql 5.6
openssl 1.0.1...
E perché una versione vecchia di MAMP?

Quella corrente è la 4.1.
La 4.1 ha i correnti minimi di sicurezza:
MySQL 5.6.34
PHP 5.6.28
OpenSSL 1.0.2

Montare MAMP su un server configurato è senza senso.

Una considerazione, se me lo consenti.
I siti professionali si costruiscono "in vivo".
Su un server in remoto.
Scegli un server LAMP con i requisiti minimi per https su un host affidabile, adatto a WP.
E lavora su quello in offline, senza se e senza ma...

E un supplemento di consiglio, chiedi e ottieni un sito con WP preinstallato e backup integrato.
Firewall e sicurezza incluse.
E soprattutto su SSD.

Il server per il sito lo paga il cliente.
Gli errori e gli sbattimenti sono a carico tuo


Abbiamo un area dove trattare questi argomenti.
Se poi avrai necessità potrai consultarci
viewforum.php?f=14" onclick="window.open(this.href);return false;
Prego un cortese moderatore di spostare la discussione lì
faxus
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 26256
Località: Due Sicilie
Contatta:

Top

Oggetto del messaggio: Re: Upgrade openssl su MacosXLion server

Messaggio Inviato: mar, 07 feb 2017 19:10

Uhm... Mi rendo conto che se hai postato la richiesta per Lion server probabilmente avrai un Mac non aggiornabile.
E quindi non puoi ospitare MAMP aggiornato.

Ma sorridi, è un motivo in più per lavorare in remoto.
Magari l'unica difficoltà di non poter fare le verifiche su browser aggiornati.

Il problema che hai è un po' complesso, fare siti su remoto con Lion puoi benissimo.
Ma non puoi navigare con versioni aggiornate di browser.
Non potrai vedere il tuo sito con Chrome e Firefox
Rispondi