Subtitles not showing in Navigator

9 replies [Last post]
frankreid
Offline
Last seen: 2 days 16 hours ago
Title:
Joined: 5 May 2016
Posts: 10
I write books and need to see the chapters and subtitles to jump around in the book. I can see the Chapters but not the subtitles. The chapters are Heading 1 and the subtitles are Heading 2 but they don’t show in the Navigator. What can I do?
RoryOF
Offline
Last seen: 6 hours 54 min ago
Title: ★★★★★
Joined: 19 Nov 2012
Posts: 331
Re: Subtitles not showing in Navigator
Have you right clicked on the heading section of Navigator and selected Outline Level 2 (or greater)?
OO 4.1.2 on Xubuntu 16.04
frankreid
Offline
Last seen: 2 days 16 hours ago
Title:
Joined: 5 May 2016
Posts: 10
Yes I did that but no change.
Yes I did that but no change. Do I have to close my file and restart Writer?
RoryOF
Offline
Last seen: 6 hours 54 min ago
Title: ★★★★★
Joined: 19 Nov 2012
Posts: 331
Re: Subtitles not showing in Navigator
No, you should not have to. Try the attached file and see if its Chapters/titles show up in Navigator.
AttachmentSize
Chapters.odt 14.77 KB
OO 4.1.2 on Xubuntu 16.04
frankreid
Offline
Last seen: 2 days 16 hours ago
Title:
Joined: 5 May 2016
Posts: 10
Yes, that’s exactly what I
Yes, that’s exactly what I want. How did you do it. Again I’m using LO/W 5.0 on Windows 7.
RoryOF
Offline
Last seen: 6 hours 54 min ago
Title: ★★★★★
Joined: 19 Nov 2012
Posts: 331
Re: Subtitles not showing in Navigator
I merely applied Heading 1 style to the Chapter title and Heading 2 to the subtitle. Simple as that.

Continue on my document – insert a chapter 3 and its subtitle and see if they show for you.

OO 4.1.2 on Xubuntu 16.04
frankreid
Offline
Last seen: 2 days 16 hours ago
Title:
Joined: 5 May 2016
Posts: 10
I had no trouble adding the
I had no trouble adding the Chapter 3 and title. It shows in the Navigator. I am using a book that was written before in another word processor then output as a .ref file to make it easy to read with Writer. Then I saved it as an .opd file. I changed all the chapter numbers to Heading 1 and the titles to Heading 2. What am I leaving out?
RoryOF
Offline
Last seen: 6 hours 54 min ago
Title: ★★★★★
Joined: 19 Nov 2012
Posts: 331
Re: Subtitles not showing in Navigator
.opd file? If that is not a typo, best format to use is odt. One trick that can help after transfer of files between applications is to open a new Writer file and also the troublesome file. Select All in the troublesome file, Copy it, switch to the blank file, and Paste.
OO 4.1.2 on Xubuntu 16.04
RoryOF
Offline
Last seen: 6 hours 54 min ago
Title: ★★★★★
Joined: 19 Nov 2012
Posts: 331
Re: Subtitles not showing in Navigator
Also, depending on the amount of formatting it can often be quicker to Save a troublesome file as plain text. Insert it into a blank Writer file, Select all to apply the default body text, then pass through the file and adjust the styling on the Chapters and subtitle by applying the correct Heading styles.
OO 4.1.2 on Xubuntu 16.04
frankreid
Offline
Last seen: 2 days 16 hours ago
Title:
Joined: 5 May 2016
Posts: 10
Oops! Yes that was a type.
Oops! Yes that was a type. odt file. To make any kind of changes between programs I often copy the entire book into a Notepad file which strips out all the unnecessary formatting. I did this with this file, and dumped it into a fresh blank Writer file. I have been changing many of the formatting for the book but I can’t get the Navigator to display the levels.

I’m using version 5.1.2.2 on Windows but on the Linux machine I have the 5.1.1.2 version. It handles it differently. What are you using?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.