Safari in inglese

Mac OS X e le sue Applicazioni

Moderatore: ModiMaccanici

Adry_59
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: dom, 09 mar 2014 11:13
Messaggi: 59
Oggetto del messaggio: Safari in inglese

Messaggio Inviato: mar, 02 ott 2018 10:22

Ciao a tutti, da qualche tempo ormai, e accaduto improvvisamente, mi ritorvo con il browser Safari in limgua inglese, mentre tutto il resto è in italiano. Come posso corregggere questo problema alquanto fastidioso? Grazie mille a tutti.
Simone.m
Hardware Expert
Hardware Expert
Avatar utente
Iscritto il: ven, 20 set 2013 23:58
Messaggi: 2951
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: mar, 02 ott 2018 13:03

Cambia la lingua di sistema in inglese, riavvia, rimetti l'italiano e riavvia di nuovo. Per un problema simile avevo risolto così :)
MacBook Pro 13" (i5 | 8GB | 256GB SSD)
iPhone SE (2017, 32GB)
Adry_59
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: dom, 09 mar 2014 11:13
Messaggi: 59
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: mar, 02 ott 2018 17:50

Grazie per la dritta, ma nonostante le tue istruzioni è rimasto tutto come prima
giovaneverdi
Music Expert
Music Expert
Avatar utente
Iscritto il: mer, 03 nov 2010 08:50
Messaggi: 347
Località: Torino
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: mar, 02 ott 2018 18:32

Non è che stai usando, per caso, Safari Technology Preview (icona viola) al posto della versione normale (icona azzurra)?
Questi sono i miei principi, e se non vi vanno... beh, ne ho degli altri! (Groucho Marx)
Kernel Panic
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 24226
Località: Sicilia
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: mar, 02 ott 2018 19:49

Almeno sapere la versione del sistema operativo che hai installato nel tuo Mac ....
Adry_59
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: dom, 09 mar 2014 11:13
Messaggi: 59
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: gio, 04 ott 2018 16:59

La versione OS è 10.14 Mojave, ma il problema si è presentato già nella versione precedente.
Adry_59
Apprendista Maccanico
Apprendista Maccanico
Iscritto il: dom, 09 mar 2014 11:13
Messaggi: 59
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: gio, 04 ott 2018 17:05

Giovane Verdi, no, uso la versione fornita con Mac Os.
Kernel Panic
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 24226
Località: Sicilia
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: ven, 05 ott 2018 12:22

Adry_59 ha scritto:
gio, 04 ott 2018 16:59
La versione OS è 10.14 Mojave, ma il problema si è presentato già nella versione precedente.
Prova a reinstallare il sistema operativo dal tuo account su App Store, con una installazione semplice non perderai alcun dato.
Paolofast
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 963
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: ven, 05 ott 2018 13:34

Mi ha chiamato un amico perché è successo anche a lui (con High Sierra).
C'è una cosa che voglio tentare, ma devo andare a casa sua e farla personalmente, perché lo conosco e farebbe disastri.
Solo che non posso andare da lui fino a martedì e quindi fino ad allora non saprò se funziona.
Intanto la scrivo qui, nel caso voleste provare prima.

Premessa: negli anni scorsi a molte persone è capitato di trovarsi con le finestre di sistema (spegnimento, riavvio, ecc.) in inglese anche se la lingua era impostata in italiano. La soluzione passava attraverso l'utente root.

Ho pensato che forse la soluzione è la stessa, ma fino a martedì non saprò se funziona.

Se qualcuno vuole provare ecco come si fa:

01) Disabilitare SIP. Per prima cosa avviate in Partizione di Recupero (Avvio con Comando-R).
02) Entrati nella Partizione di Recupero avviate da menù il Terminale.
03) Inserite il comando csrutil disable --without debug.
04) Uscite da Terminale e riavviate.
05) Aprite Utility Directory. Sta in <Disco principale>/Sistema/Libreria/CoreServices
06) Sbloccate il lucchetto e dal menù "Modifica" scegliete "Abilita utente root".
07) Se è la prima volta, dovrete assegnare una password all'utente root.
08) Fate logout dal vostro utente.
09) Fate login come root. Molto probabilmente sarà in inglese. Se lo è, qui possiamo forse risolvere il problema.
10) Aprite Preferenze di Sistema dal menù Mela. Scegliete "Lingua e zona" e impostate l'italiano come prima lingua.
11) Logout dall'utente root
12) Login nel vostro utente.
13) Visto che siete impazienti, aprite Safari e guardate se è andato a posto.
14) Prima di festeggiare (o deprimervi se non ha funzionato) ricordatevi di riabilitare SIP.
15) Riavviate per entrare in Partizione di Recupero (Avvio con Comando-R).
16) Entrati nella Partizione di Recupero avviate da menù il Terminale.
17) Inserite il comando csrutil enable.
18) Uscite da Terminale e riavviate.

Fatto.

Ovviamente se nel frattempo qualcuno trova una soluzione migliore, ben venga.
Kernel Panic
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 24226
Località: Sicilia
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: ven, 05 ott 2018 14:46

Se ha funzionato in quel caso potrebbe funzionare anche in questo.



Io però tendenzialmente la penserei come te ....
Paolofast ha scritto:
gio, 13 set 2018 18:45
Parliamoci chiaro: finché root attiva e SIP disabilitato lo tengono esperti come faxus e Frag®ua, tutto ok.
Ma per le persone inesperte che arrivano qui in cerca di consigli, sappiate che se non sapete molto bene cosa fate e imitate i due di sopra, è come correre palleggiando con una boccia di nitroglicerina sbattendola di tanto in tanto contro un muro: potrebbe esplodere.
faxus
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 25068
Località: Due Sicilie
Contatta:

Top

Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: ven, 05 ott 2018 16:13

Si tratta di un difetto casuale iniziato con Sierra.

C'era della documentazione all'epoca.
Si è trascinato in High Sierra, quindi probabile sia ancora attivo in Mojave.

A volte può risolversi, se si tratta di una corruzione nel sistema.
Terminale:

Codice: Seleziona tutto

defaults write -g AppleLanguages '(it, en)'
Seguito da

Codice: Seleziona tutto

chflags uchg Library/Preferences/.GlobalPreferences.plist
Poi riavvia.
Sia che sia stato sistemato o no, ripristina il controlla della preferenza

Codice: Seleziona tutto

chflags nouchg Library/Preferences/.GlobalPreferences.plist
Non ne trovo documentazione, ma posso ipotizzare che sia dovuto al cambio del default.
Parto dall'ipotesi che sia provocato, il problema, da una versione che in passato hai installato come beta.
Il comando l'ho arrangiato perché non è documentato, quindi se va, va...

Codice: Seleziona tutto

defaults write com.apple.Safari AppleLanguages '(it)'
Tutto questo va sempre eseguito con Safari chiuso.

Se non funziona non c'è soluzione.
È una variazione immutabile ormai consolidata.
L'unica soluzione conosciuta, senza la reinstallazione da zero, è cambiare utente.

La riprova la puoi fare subito.
Crea un altro utente amministratore e se Safari è in italiano è quello il problema
Paolofast
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 963
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: mer, 10 ott 2018 11:16

Qualcuno ha capito perché succede?
faxus
Pro-Expert 
Pro-Expert 
Avatar utente
Iscritto il: lun, 02 giu 2014 15:12
Messaggi: 25068
Località: Due Sicilie
Contatta:

Top

Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: mer, 10 ott 2018 14:59

Paolofast ha scritto:
mer, 10 ott 2018 11:16
Qualcuno ha capito perché succede?
faxus ha scritto:
ven, 05 ott 2018 16:13
Si tratta di un difetto casuale iniziato con Sierra.

C'era della documentazione all'epoca.
Si è trascinato in High Sierra...
Quindi è un bug.

Che si verifica in alcune installazioni e non in altre.
Non è stato individuato il motivo specifico, probabile un'impostazione software che confligge.

Si risolve, a volte agendo sull'impostazione generale di sistema o del browser.
Sempre reinstallando.

Per il resto vale la considerazione già fatta, prima, in un topic assimilabile.
Si tratta di corruzioni del software, in questo caso si sa anche che è dovuta a chi lo ha sviluppato
Paolofast
Expert
Expert
Avatar utente
Iscritto il: dom, 07 gen 2018 20:00
Messaggi: 963
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: mer, 10 ott 2018 15:09

Bene, a questo punto la domanda è: delle varie soluzioni prospettate, qualcuna è stata provata dalle "vittime" che hanno postato qui? Ed ha funzionato?

Mi piacerebbe dire: "Oggi ho provato la soluzione X ed ha funzionato", ma purtroppo la persona con questo problema ha rimandato l'appuntamento alla settimana prossima.
Quindi, se nessuno le prova prima, la settimana prossima spero di riuscire finalmente a mettermi davanti al computer incriminato ed a provare a sistemarlo.
E posterò i risultati.
Kernel Panic
Software Expert Gold
Software Expert Gold
Avatar utente
Iscritto il: sab, 08 gen 2011 14:03
Messaggi: 24226
Località: Sicilia
Oggetto del messaggio: Re: Safari in inglese

Messaggio Inviato: mer, 10 ott 2018 21:21

Guarda che, in questo come in altri forum, non sono pochi gli utenti che "si dimenticano" di dare un riscontro circa l'utilità o meno dei suggerimenti ricevuti.

:)
Rispondi