iMaccanici Assistenza Apple
Forum
Oggi è sab, 25 mar 2017 10:46

Tutti gli orari sono UTC + 1 ora




Apri un nuovo argomento Rispondi all’argomento  [ 26 messaggi ]  Vai alla pagina 1, 2  Prossima
Autore Messaggio
MessaggioInviato: ven, 10 feb 2017 15:34 
Non connesso
Open Office Expert
Open Office Expert
Avatar utente

Iscritto il: sab, 02 mar 2013 15:04
Messaggi: 361
Ciao a tutti, già in passato sono intervenuto sull'argomento del software fornito da Sogei all'Agenzia delle Entrate per le dichiarazioni e gli invii di tipo fiscale: viewtopic.php?f=9&t=33897.
Veniamo al problema di quest'anno: per conto del condominio dove abito devo certificare le ritenute d'acconto effettuate per conto dei fornitori del condominio stesso. Il tutto si fa scaricando un'applicazione Java disponibile sul sito. Una volta entrati nella logica del software, è abbastanza semplice la compilazione (ho solo 2 fornitori, roba da ridere rispetto agli amministratori professionisti).
Al momento di chiedere la stampa di quanto compilato arriva la sorpresa:
Allegato:
Schermata 02-2457793 alle 16.16.58.png
Schermata 02-2457793 alle 16.16.58.png [ 9.19 KiB | Osservato 402 volte ]

Non è un problema di stampante, che funziona benissimo, ma qualcosa a monte perché prima di stampare il software Sogei genera un file PDF che OSX visualizza in automatico con Anteprima e questo non avviene.
Memore delle esperienze del passato ho provato in ambiente Linux: stesso risultato. Provato anche con Windows 7 e, sorpresa e rabbia! qui tutto funziona.
Ho scritto al servizio assistenza dell'Agenzia delle Entrate e ho appena ricevuto questa risposta:
Gentile contribuente,
Il diagnostico da lei riportato non e' relativo ad errori o incompatibilita' dei software o delle procedure messi a disposizione dell'Agenzia delle Entrate.
Cordiali saluti

C'è qualche utente che ha avuto lo stesso problema?

P.S. Java è aggiornato.

_________________
Charlie
iMac 27" metà 2012- OSX 10.7.5 Lion/ macOS 10.12 Sierra (dual boot)

http://www.charlieopenoffice.altervista.org


top
 Profilo  
 
MessaggioInviato: gio, 16 feb 2017 14:15 
Non connesso
Expert
Expert
Avatar utente

Iscritto il: mer, 10 giu 2009 12:37
Messaggi: 1083
charlie ha scritto:
P.S. Java è aggiornato.


Ed il problema è proprio questo.

Che versione JavaVM?
Che versione JavaRunTime
Di che pacchetto AdE parliamo precisamente?
Che S.O.?


top
 Profilo  
 
MessaggioInviato: gio, 16 feb 2017 14:27 
Non connesso
Pro-Expert 
Pro-Expert 
Avatar utente

Iscritto il: lun, 02 giu 2014 14:12
Messaggi: 16275
Località: Due Sicilie
GLOP ha scritto:
... Che versione JavaVM?
Che versione JavaRunTime...

Non ha importanza, né queste né altro.

L'importante è installare un Java con contenuti "legacy".
Per esempio il Kit di sviluppo SE
viewtopic.php?f=5&t=19867&start=60#p433509


top
 Profilo WWW  
 
MessaggioInviato: gio, 16 feb 2017 14:36 
Non connesso
Expert
Expert
Avatar utente

Iscritto il: mer, 10 giu 2009 12:37
Messaggi: 1083
faxus ha scritto:
Non ha importanza, né queste né altro.


Ti devo contraddire.


top
 Profilo  
 
MessaggioInviato: gio, 16 feb 2017 15:06 
Non connesso
Pro-Expert 
Pro-Expert 
Avatar utente

Iscritto il: lun, 02 giu 2014 14:12
Messaggi: 16275
Località: Due Sicilie
GLOP ha scritto:
... Ti devo contraddire.

Il fatto non costituirebbe un problema... Hahaha.

Questa mia affermazione deriva da soluzioni che hanno avuto la loro efficacia.
Alcuni problemi erano stati posti, in passato, dalla necessità di installare la "Apple-Java" version SE 6 Runtime Mac
https://support.apple.com/kb/dl1572?locale=it_IT
Perché era una versione legacy con versioni diffuse e rimaste a stadi precedenti.

Ma le versioni di sviluppo contengono e sono funzionali a tutte le versioni precedenti.
Quindi sono funzionali alla necessità.

Se hai altro che può risolvere, o semmai quanto detto non fosse vero, ben venga...


top
 Profilo WWW  
 
MessaggioInviato: gio, 16 feb 2017 15:15 
Non connesso
Open Office Expert
Open Office Expert
Avatar utente

Iscritto il: sab, 02 mar 2013 15:04
Messaggi: 361
Il pacchetto è CUR17.jnip, si scarica qui: http://www.agenziaentrate.gov.it/wps/content/nsilib/nsi/home/cosadevifare/dichiarare/dichiarazionisostitutiimposta/certificazione+unica+2017/software+di+compilazione+certificazione+unica+2017/indice+sw+compilazione+cu+2017
Java: La Java Virtual Machine versione 1.7 è scaricabile dal sito http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html.
Il sistema operativo, quello in firma: OSX 10.7.5, in linea con le richieste.

Allegato:
Schermata 02-2457801 alle 15.12.34.png
Schermata 02-2457801 alle 15.12.34.png [ 95.15 KiB | Osservato 292 volte ]


Ribadisco che tutto funziona fino alla richiesta di stampare.

_________________
Charlie
iMac 27" metà 2012- OSX 10.7.5 Lion/ macOS 10.12 Sierra (dual boot)

http://www.charlieopenoffice.altervista.org


top
 Profilo  
 
MessaggioInviato: gio, 16 feb 2017 15:43 
Non connesso
Expert
Expert
Avatar utente

Iscritto il: mer, 10 giu 2009 12:37
Messaggi: 1083
Crea un nuovo utente, installa la JavaVM 1.7 (strettamente quella, non versioni successive). Poi installa il pacchetto AdE.
Poi dicci se funziona.


top
 Profilo  
 
MessaggioInviato: gio, 16 feb 2017 15:47 
Non connesso
Pro-Expert 
Pro-Expert 
Avatar utente

Iscritto il: lun, 02 giu 2014 14:12
Messaggi: 16275
Località: Due Sicilie
GLOP ha scritto:
... installa la JavaVM 1.7 (strettamente quella, non versioni successive)...

Ti devo contraddire...


top
 Profilo WWW  
 
MessaggioInviato: gio, 16 feb 2017 15:50 
Non connesso
Expert
Expert
Avatar utente

Iscritto il: mer, 10 giu 2009 12:37
Messaggi: 1083
faxus ha scritto:
GLOP ha scritto:
... installa la JavaVM 1.7 (strettamente quella, non versioni successive)...

Ti devo contraddire...

Penso di amarti


top
 Profilo  
 
MessaggioInviato: gio, 16 feb 2017 16:44 
Non connesso
Pro-Expert 
Pro-Expert 
Avatar utente

Iscritto il: lun, 02 giu 2014 14:12
Messaggi: 16275
Località: Due Sicilie
Hohoho....


top
 Profilo WWW  
 
MessaggioInviato: gio, 16 feb 2017 17:38 
Non connesso
Open Office Expert
Open Office Expert
Avatar utente

Iscritto il: sab, 02 mar 2013 15:04
Messaggi: 361
GLOP ha scritto:
Crea un nuovo utente, installa la JavaVM 1.7 (strettamente quella, non versioni successive).

Si rifiuta di installare quella versione perché ne trova già una più recente.
GLOP ha scritto:
Poi installa il pacchetto AdE.

Non si deve installare niente, si scarica un file eseguibile con Java.

_________________
Charlie
iMac 27" metà 2012- OSX 10.7.5 Lion/ macOS 10.12 Sierra (dual boot)

http://www.charlieopenoffice.altervista.org


top
 Profilo  
 
MessaggioInviato: gio, 16 feb 2017 19:06 
Non connesso
Maccanico assiduo
Maccanico assiduo
Avatar utente

Iscritto il: lun, 31 ott 2016 18:20
Messaggi: 107
Località: https://is.gd/axusiw
forse puoi confrontare con la versione di Java che hai su windows 7

_________________
Essere vivo richiede uno sforzo di gran lunga maggiore del semplice fatto di respirare. (Pablo Neruda)


top
 Profilo  
 
MessaggioInviato: gio, 16 feb 2017 20:46 
Non connesso
Expert
Expert
Avatar utente

Iscritto il: mer, 10 giu 2009 12:37
Messaggi: 1083
charlie ha scritto:
Si rifiuta di installare quella versione perché ne trova già una più recente.

Devo pensare che non hai creato un nuovo utente o che Java sia disponibile per tutti gli utenti.
charlie ha scritto:
Non si deve installare niente, si scarica un file eseguibile con Java.

Ok, diciamo che installare non è il verbo di tuo gradimento (il path di istallazione del file che lanci è all'interno di ~/Library/... e via dicendo (sto scrivendo da tt ed ovviamente non ricordo a memoria).
Chi ti scrive è un povero cretino che ci ha sbattuto la testa per un paio di settimane prima di riuscirci.
Poi, se uno non si vuole fare aiutare è inutile che chiede, meglio mentire e scrivere: "ho provato e non funziona".


top
 Profilo  
 
MessaggioInviato: gio, 16 feb 2017 21:24 
Non connesso
Apprendista Maccanico
Apprendista Maccanico

Iscritto il: dom, 22 gen 2017 20:34
Messaggi: 50
Località: ai confini dell'Impero Romano
Entro anch'io nel dibattito per cercare di dare una mano a charlie.
Mi rivolgo perciò direttamente a lui.
Ho pensato di simulare sul mio iMac (nuovo) la tua operazione, in questo senso:
- ho scaricato il software di Sogei chiamato "UNI16" in pratica quello che prepara la dichiarazione redditi delle PF ed alla fine scrive il file che entrerà poi nell'applicativo File Internet (dentro Desktop Telematico).
Certamente non è lo stesso pacchetto che tu hai utilizzato, ma verosimilmente, alla fine, produce sempre un file che verrà poi inviato all'Ag.Entrate;
- ho lanciato il mio software e, con molta attenzione, ho compilato tutti i campi che mi servivano (la maggior parte di questi già valorizzati perché presi dalla precompilata 2016 dell'Agenzia);
- compilati bene tutti i Quadri, alla fine, prima di uscire, ho chiesto la stampa del documento;
- accesa la mia stampantina (una HP Deskjet 2050), ho dato l'ok, e mi ha stampato tutte le 11 pagine della dichiarazione.
Per me, quindi, è andato tutto OK.
Conclusione.
Prova a verificare il contenuto del tuo pacchetto "CUR17".
Il software che ho utilizzato, UNI16, mi ha creato queste 4 cartelle :
- arc (contiene la dich. redditi)
- F24 (vuota)
- stampe (contiene la stampa della d.r.)
- UNI16 (contiene a sua volta le cartelle dic (valorizzata) e localAppRoot (vuota))
più 2 file : - logerr.txt.lck (vuoto)
- logerr.txt (valorizzato di 122 KB ed è il log di tutte le operazioni eseguite).
Apri il log (è molto grande) e vedi se in fondo al log è scritto qualcosa circa la stampa (che è poi il tuo problema!).
Il mio log non ha dato alcuna segnalazione di anomalia.
Questo è quello che ti posso dire.
Mi auguro invece che possa esserti utile.

_________________

sono aggiornato a macOS Sierra - Versione 10.12.3 con :
iMac (Retina 4K, 21.5-inch, Late 2015) - Processore 3,1 GHz Intel Core i5 (i5-5675R) CPU: 4-core
Memoria 8 GB 1867 MHz DDR3 - Scheda grafica Intel Iris Pro Graphics 6200 1536 MB


top
 Profilo  
 
MessaggioInviato: ven, 17 feb 2017 08:14 
Non connesso
Open Office Expert
Open Office Expert
Avatar utente

Iscritto il: sab, 02 mar 2013 15:04
Messaggi: 361
GLOP ha scritto:
Devo pensare che non hai creato un nuovo utente o che Java sia disponibile per tutti gli utenti.

Il nuovo utente l'ho creato, penso sia valida la seconda ipotesi.
GLOP ha scritto:
Ok, diciamo che installare non è il verbo di tuo gradimento ….
Chi ti scrive è un povero cretino che ci ha sbattuto la testa per un paio di settimane prima di riuscirci.
Poi, se uno non si vuole fare aiutare ...

Perché te la prendi? Ti ho solo contraddetto dicendo quello che penso, magari sbagliando.

Comunque, grazie :) .

_________________
Charlie
iMac 27" metà 2012- OSX 10.7.5 Lion/ macOS 10.12 Sierra (dual boot)

http://www.charlieopenoffice.altervista.org


Ultima modifica di charlie il ven, 17 feb 2017 08:39, modificato 1 volta in totale.

top
 Profilo  
 
Visualizza ultimi messaggi:  Ordina per  
Apri un nuovo argomento Rispondi all’argomento  [ 26 messaggi ]  Vai alla pagina 1, 2  Prossima


Tutti gli orari sono UTC + 1 ora


Chi c’è in linea

Visitano il forum: Google [Bot] e 3 ospiti


Non puoi aprire nuovi argomenti
Non puoi rispondere negli argomenti
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi inviare allegati

Cerca per:
Vai a:  
Design by iMaccanici
Powered by phpBB® Forum Software © phpBB Group
Traduzione Italiana phpBBItalia.net basata su phpBB.it 2010